
ส่วนประกอบของ Flash 8

เมนบูาร์ (Menu Bar)
ไทมไลน ์(Timeline)

Property Inspector

พาเนล (Panels)

สเตจ (Stage)

Pasteboard

เมนบูาร์ (Menu Bar)

เมนบูารเ์ปน็แถบทีร่วบรวมคำสัง่ในการใชง้านทัง้หมดเกีย่วกบัการสรา้งชิน้งาน และการตัง้คา่ตา่ง ๆ
ที่เกี่ยวกับการใช้งานโปรแกรม

ทูลบ็อกซ์ (Toolbox)



ไทมไลน ์(Timeline)

ไทมไลน ์ใช้สำหรบัสร้างหรอืกำหนดรายละเอยีดของการเคลือ่นไหว ไทมไลนถ์กูสรา้งจากเฟรมทีเ่รยีง
ตอ่ ๆ กนัในแนวนอน เฟรมสามารถปลอ่ยวา่งได ้สามารถมเีนือ้หาได ้และสามารถมคียีเ์ฟรมได ้       ไทมไลน์
ถกูสรา้งดว้ยการเรยีงกนัของเลเยอรท์ีมี่เนือ้หาและโคด้ของ Flash โดยแตล่ะเลเยอรจ์ะม ี1แถว ตวัชีต้ำแหนง่
เฟรม Playhead จะชีต้ำแหนง่เฟรมทีก่ำลงัทำงานอยูบ่นไทมไ์ลนใ์นขณะนัน้

Playhead

เลยอร์ (Layer)

สเตจ (Stage)
สเตจ (Stage)

Pasteboard

พืน้ทีสี่ขาวบรเิวณกลางจอคอื สเตจ เปน็พืน้ทีใ่ช้จัดวางออบเจก็ตต์า่ง ๆ ทีต่อ้งการแสดงใหเ้หน็ใน
ช้ินงาน ส่วนพืน้ทีสี่เทาดา้นนอกบรเิวณสขีาวคอื Pasteboard เปน็บรเิวณทีส่ามารถนำออบเจก็ตต์า่ง ๆ มาวาง
พกัไวห้รอืวางซอ่นไวไ้ดเ้พราะบรเิวณนีจ้ะไมแ่สดงผลเวลาทีเ่รา Export Movie เปน็ไฟล ์.SWF

พาเนล (Panels) พาเนล (Panels)

พาเนล เปน็กรอบควบคมุตา่ง ๆ ในการสรา้งและแกไ้ขงาน Flash
พาเนลสามารถทำการเปดิปดิไดจ้ากเมนคูำสัง่ได ้นอกจากนัน้เรายงัสามารถ
ส่ัง Group พาเนลใหร้วมกนัเปน็กลุม่ไดอี้กดว้ย



ทูลบ็อกซ ์(Toolbox)

ทลูบ็อกซ ์เปน็กลอ่งทีร่วมเครือ่งมอืตา่ง ๆ ทีใ่ช้ในการสรา้งและปรบัแตง่ออบเจก็ต ์โดย
แตล่ะเครือ่งมอืในทลูบ็อกซจ์ะมลัีกษณะเปน็ไอคอนรปูภาพทีเ่ราสามารถใชง้านได ้ โดยเมือ่
เราเลอืกเครือ่งมอืตา่ง ๆ เพือ่ใช้งานแลว้เราสามารถปรบัแตง่เพิม่เตมิที ่Options ดา้นลา่งของ
ทลูบ็อกซ ์ไ์ด้

Options

Property Inspector

Property Inspector เปน็พาเนลชนดิหนีง่ทีแ่สดงคณุสมบตัติา่ง ๆ ของออบเจก็ตท์ีเ่ราคลกิเลอืก ซ่ึงเรา
สามารถปรบัแตง่คณุสมบตัเิหลา่นีไ้ด ้ทัง้นีร้ายละเอยีดของ Property Inspector จะเปลีย่นไปตามออบเจก็ตท์ี่
เราเลือกอยู่ในขณะนั้น

การสรา้งชิน้งานใหม่
การเริม่ตน้สรา้งชิน้งานใด ๆ ใน Flash นัน้ตอ้งทำการกำหนดคา่และคณุสมบตัขิองไฟลง์านทีเ่ราตอ้ง

การเสยีกอ่น เพือ่ใหไ้ดไ้ฟลท์ีต่รงกบังานทีจ่ะนำไปใช ้หลงัการทำงานเสรจ็และจะนำไฟลไ์ปเผยแพร ่ ซ่ึงเรา
สามารถทำได ้3 แบบคอื

1. สร้างชิน้งานใหมด่ว้ยการกำหนดรปูแบบเอง
2. สร้างโดยใชเ้ทมเพลต (Template)
3. สร้างจากไฟลส์ำเรจ็รูป



สรา้งชิน้งานใหมด้่วยการกำหนดรปูแบบเอง

ไฟลง์านในรปูแบบปกต ิทีใ่ช้สร้างงานทัว่ไป
ไฟล์งานที่เหมาะกับการสร้างพรีเซนเตชั่นทั่วไป
ไฟล์สร้างฟอร์มสำหรับทำโปรแกรมใช้งานทั่วไป
เปน็ไฟลท์ีใ่ช้สำหรบัเขยีนสครปิต ์ (เหมาะกบัเรยีกสครปิตจ์ากภายนอก)
เหมาะสำหรับเขียนสคริปต์ที่ต้องการติดต่อกับเซิร์ฟเวอร์
เหมาะสำหรบังานเขยีนสครปิตท์ีท่ำงานรว่มกบั Java
เปน็การรวมกลุม่งานทีเ่ราสรา้งทัง้หมดใหอ้อกมาเปน็ Project

สร้างชิ้นโดยใช้เทมเพลต

เทมเพลตสำหรบัสร้างงานโฆษณา เช่น แบนเนอร ์ป็อบอัพ
เทมเพลตที่เป็นรูปแบบของหน้าต่างโปรแกรมทั่วไป
เทมเพลตที่ใช้สร้างงานสำหรับแสดงบนโทรศัพท์มือถือระบบที่ใช้กันทั่วโลก
เทมเพลตที่ใช้สร้างงานสำหรับแสดงบนโทรศัพท์มือถือระบบที่ใช้ในญี่ปุ่น
เทพเพลตทีใ่ช้สำหรบัสร้างงานแอนเิมชัน่สำหรบั พีดเีอ
เทมเพลตสำหรับแสดงภาพถ่ายอย่างต่อเนื่อง
เทพเพลตสำหรับสร้างสไลด์ภาพถ่ายอย่างต่อเนื่อง

เทมเพลตสำหรบัสร้างคำถามในลกัษณะ e - Learning
เทมเพลสำหรับสร้างพรีเซนเตชั่นในการนำเสนอ

การกำหนดขนาดของชิน้งาน
สามารถกำหนดได ้3 ที่

1. จากเมน ูModify > Document...
2. จาก Property Inspector
3. จากการดบัเบ้ิลคลิกช่องแสดงจำนวน Frame บน Timeline



๐ Title : กำหนดชือ่ใหก้บัช้ินงาน
๐ Description :กำหนดรายละเอยีดทีเ่กีย่วกบัช้ินงาน
๐ Math : เป็นการกำหนดขนาดของ Stage โดยมรีายละเอยีดดงันี้

กำหนดให ้Stage มีขนาดใหญสุ่ดเทา่ทีจ่ะพมิพไ์ด้
กำหนดใหพ้ืน้ทีก่ารทำงานรอบ Stage มีขนาดกบั
เนือ้หาของเรา (เราสามารถกำหนดหวัขอ้นีไ้ดต้อ่
เมื่อเราได้นำออบเจ็กต์ไปวางไว้ทางซ้ายมือของจอ)
ปรับ Stage ใหมี้คา่มาตรฐาน คอื 550 x 400 พิกเซล

๐ Background color : คลกิที ่          เพือ่กำหนดสใีหพ้ืน้ที ่Stage
๐ Frame Rate : กำหนดอตัราเรว็ในการแสดงภาพเคลือ่ไหว (วดัเปน็ เฟรมตอ่วินาท ีโดยอตัรามาตรฐาน
เทา่กบั 12 fps
๐ Ruler Units : เลอืกหนว่ยวดัของไมบ้รรทดั

การยอ่ / ขยายมมุมองของสเตจ

 คลกิที ่Zoom Tool          จากทลูบ็อกซ ์แลว้คลกิเลอืกลกัษณะการซมูที ่Options ในทลูบ็อกซด์งันี้

๐ ปกตหิลังจากคลกิที ่Zoom Tool แล้ว เมาสจ์ะเปลีย่น
เปน็รปูแวน่ขยาย และเมือ่คลกิ จะเปน็การขยายมมุมอง
ให้ใหญข้ึ่น (Zoom In)

๐ หากตอ้งการลดขนาดของมมุมองใหมี้ขนาดเลก็ลง
(Zoom Out) ระหวา่งทีค่ลกิเมาสใ์หก้ดปุม่ Alt ดว้ยโดย
เมาส ์จะเปลีย่นจากรปูเครือ่งหมายบวกเปน็
เครื่องหมายลบ

๐ ระหวา่งทีก่ำลงัเลอืกเครือ่งมอื Zoom อยูน่ัน้เราสามารถทำการยอ่/ขยายมมุมองได้
โดยการคลกิรปู                           ที ่Options ในทลูบอกซ์



๐ กดปุม่ Ctrl + จะเปน็การขยายขนาดมมุมองใหใ้หญข่ึน้
๐ กดปุม่ Ctrl - จะเปน็การลดขนาดมมุมองใหเ้ล็กลง

๐ เราสามารถปรบัขนาดมมุมองของสเตจไดด้ว้ยการเลอืกขนาด
ตามทีก่ำหนดไว ้ทางขวามอืในหนา้ตา่ง ไทมไ์ลน์
Fint in Window : เป็นการกำหนดใหแ้สดงใหพ้อดกัีบขนาดของ
พื้นที่การทำงานที่ปรากฏในหน้าจอ
Show Frame : เป็นการกำหนดใหแ้สดงเฉพาะสเตจใหใ้หญเ่ตม็
พื้นที่หน้าต่างทำงาน
Show All : เพือ่แสดงใหเ้หน็ออบเจก็ทัง้หมด
xxx % : เปน็การกำหนดขนาดตามตวัเลขทีเ่ลอืก

๐ หากทำการดบัเบิล้คลกิที ่           จะเปน็การปรบัขนาดมมุมองใหเ้ทา่กบั 100 %

๐ หากทำการดบัเบิล้คลกิที่     จะเปน็การปรบัมุมมองใหพ้อดกีบัขนาดของพืน้ทีก่ารทำงาน

การใช ้Hand Tool

Hand Tool เปน็เคลือ่งมอืในการเคลือ่นมมุมองใหต้รงกบัความตอ้งการของเรา โดยใหเ้ราคลกิเมาสค์า้งไว้
บนสเตจหรอืบนพืน้ทีท่ำงานกไ็ด ้แลว้เลือ่นหนา้จอไปยงัสว่นทีต่อ้งการแสดง
(Shortcut ของ Hand Tool คือปุ่ม Space bar)

การจัดการกับหน้าจอก่อนเริ่มต้นทำงาน

ในโปรแกรม Flash ประกอบดว้ยหนา้ตา่งพาเนลและแถบเครือ่งมอืจำนวนมาก ในหวัขอ้นีจ้ะ
นำเสนอตวัตวัอยา่งการจดัรปูแบบหนา้จอของโปรแกรมเพือ่การใชง้านทีส่ะดวกทีสุ่ด ดว้ยหลกัการงา่ย ๆ ดงั
ต่อไปนี้

ปรับความกวา้งและความสงูขององคป์ระกอบตา่ง ๆ
เราสามารถปรบัความกวา้งและความสงูขององคป์ระกอบตา่ง ๆ ของ Flash ไดโ้ดยมวีธีิการ

ดังต่อไปนี้



๐เราสามารถปรับความกว้างและความสูงได้โดย
การคลิกเมาส์และทำการลากบริเวณขอบรอยต่อของ
พาเนลตา่ง ๆ

๐ หากเราทำการคลกิทีปุ่่มดงัรปู จะเปน็การสลบัระหวา่งการเปดิและการปดิ
การแสดงผลของกลุม่ของพาเลทตา่ง ๆ

คลิกเมาส์และทำการลากบริเวณขอบรอยต่อของ
พาเนลตา่ง ๆ  เพือ่ปรับขนาดความกวา้งความสงู

๐ ในส่วนของ Timeline จะมีการปดิและการเปดิการแสดงผลไมเ่หมอืนกบัส่วน
อ่ืนโดยสามารถ การสลบัระหวา่งการเปดิและการปดิการแสดงผลของ Timeline ได้โดย
การคลิกที่ปุ่มดังรูป

จดัการทลูบ็อกซ์

เราสามารถแยกทูลบ็อกซ์ออกมาเป็นหน้าต่างอิสระได้โดยใช้เมาส์ดับเบิ้ลคลิกที่ส่วนบนของทูลบ็อกซ์
หนา้ตา่งทลูบ็อกซก์จ็ะแยกออกมา และเมือ่ใดตอ้งการใหน้ำทลูบ็อกซไ์ปยดึไปวท้ีเ่ดมิ กใ็หท้ำการดบัเบิล้คลกิ
ที่ส่วนหัวของหน้าต่างทูลบ็อกซ์

๐ ดบัเบิล้คลกิเพือ่แยกทลูบ็อกซ์
ออกมา

๐ ดบัเบิล้คลิกเพือ่นำกลบั
ไปยึดไว้ที่เดิม



จัดการพาเนล
เปิด/ปิดพาเนล
๐ เราสามารถทำการเปดิ/ปิดพาเนลไดโ้ดยเลอืกคำสัง่ Window > ช่ือพาเนลทีต่อ้งการใชง้าน (ใหมี้

เครือ่งหมายถกูหนา้ชือ่พาเนลทีต่อ้งการเพือ่ใหแ้สดงพาเนล และใชค้ำสัง่เดยีวกนัยกเลกิเครือ่งหมายถกูหนา้
ชื่อพาเนลที่ต้องการซ่อนไว้)

๐ เราสามารถปดิพาเนลโดยคลกิทีปุ่่มเมน ู            บริเวณ
ขวามอืของพาเนลทีต่อ้งการปดิแลว้เลอืกคำสัง่ Close panel group

๐ พาเนลบางพาเนลเรามกัใชง้านรว่มกนั หรอืมีลักษณะเหมอืนกนั เรากส็ามารถทำการรวมกลุม่ได้
ตามความตอ้งการเพือ่ความสะดวกในการใชง้าน โดยใหค้ลกิทีปุ่่ม         แลว้คลกิเลอืกคำสัง่
Grop <ช่ือพาเนล>  With

รวมกลุ่มพาเนล



๐ เราสามารถยา้ยตำแหนง่พาเนลไดโ้ดยการคลกิเมาสท์ีปุ่่ม      และทำการลาก
ออกมาจากตำแหน่งเดิม

การย้ายตำแหน่งพาเนล

๐ หากตอ้งการนำพาเนลกบัไปไวท้ีเ่กา่กใ็หท้ำการ
คลกิเมาสท์ีปุ่่ม     และทำการลากกลบัไปไวยั้งตำแหนง่เดมิ

๐ ในระหวา่งทำงาน
เราอาจจำเป็นต้องใช้หรือไม่ใช้พาเนล
ซึ่งบางครั้งเราอาจต้องการให้พื้นที่การ
ทำงานเต็มจอและซ่อนพาเนลที่ไม่ต้องการ
โดยใชค้ำสัง่ Window > Hide Panels
(หรอืกดคย์ีลัด F4)

การซ่อน/แสดงพาเนลและปิดพาเนลทั้งหมด

๐ ในระหวา่งทำงาน เราอาจทำการเปลีย่นแปลงหนา้การแสดงผลของหนา้จอ
ตามความต้องการของเราซึ่งในบางครั้งเราอาจต้องการให้หน้าจอมีลักษณะการจัด
เรยีงองคป์ระกอบตา่ง ๆ เหมอืนเดมิ กส็ามารถทำไดโ้ดยใชค้ำสัง่
 Window > Workspace Layout > Default

การปรับแต่งการแสดงผลของหน้าจอให้กลับสู่ค่าเริ่มต้น



๐ เราสามารถทำการบนัทกึรปูแบบการแสดงผลของหนา้จอ การจดัองคป์ระกอบของพาเนลตา่ง ๆ ได้
ตามความตอ้งการของเราโดยใชค้ำสัง่ Window > Workspace > Layout (และทำการตัง้ชือ่ตามทีเ่ราตอ้งการ)

การปรับแต่งการแสดงผลของหน้าจอให้กลับสู่ค่าเริ่มต้น

เนือ้หา ทัง้หมดทีท่ำงานกบั Flash จะถกูวางอยูบ่น Timeline ตวัชีต้ำแหนง่ (Playhead) จะเลือ่นไป
ตามแนวของ Timeline และแสดงเฟรมทีอ่ยู่ ณ ขณะนัน้ โดยเราสามารถเลือ่น ตัวช้ีตำแหนง่ไปบน Timeline
ไดใ้นการแกไ้ขงาน Flash ซ่ึง Timeline ประกอบไปดว้ย Frame และ Keyframe ซ่ึงอาจเปน็ชว่ง ๆ หรอืวา่ง
เปลา่กไ็ด ้Frame ตา่ง ๆ สามารถซอ้นเปน็ชัน้ ๆ ไดโ้ดยใชค้วามสามารถของ Layer

Keyframe คอื จุดการเปลีย่นแปลงตา่ง ๆ ทีเ่กดิขึน้บน Timeline เราอาจมเีนือ้หาใหมใ่น keyframe
หรอืทำการเปลีย่นแปลง Animation บางสว่น      ส่วน Frame จะถกู ใช้ระหวา่ง Keyframe เพือ่เตมิส่วนของ
Animation หรอืไทมไ์ลน ์เราไมจ่ำเปน็ตอ้งแกไ้ขเนือ้หาตา่ง ๆ ใน Frame เพราะหากเราทำการแกไ้ข Frame
จะกลายเปน็ Keyframe ต่อไป

การใช ้Timeline และ Frame เบ้ืองตน้

ปุ่มแสดง Layer ให้เป็น Out line
ปุ่ม ล็อก/ปดลอ็ก Layer

ปุ่ม แสดง/ซ่อน Layer

รูปดินสอแสดงถึงการเลือกและทำงานอยู่บน
Layer ทีเ่ลอืกอยู่

แสดง/ซ่อน Timeline

Layer

ช่ือ Layer

สร้าง Layer
ใหม่

สร้าง Motion Guidelayer

สร้าง Layer folder

ลบ Layer

Playhead



Layer เปน็เหมอืนการวางแผน่ใสซอ้นทบักนัเปน็ลำดบัช้ันเพิม่ขึน้มาเรือ่ย ๆ โดยบรเิวณของ Layer
ทีไ่ม่มีรูปจะเหน็ทะุลถึุง Layer ดา้นลา่ง   Layer แตล่ะ Layer จะมคีณุสมบตัเิปน็ของตวัเอง การแกไ้ขเนือ้หา
หรอื Animation ใด ๆ กับ Layer หนึง่จะไมส่่งผลกบัอีก Layer หนึง่

ความเขา้ใจเกีย่วกบั Layer เบ้ืองตน้

นักออกแบบและพฒันา Flash มักนยิมจัด
อ็อบเจ็กต์ประเภทเดียวกันไว้บนเลเยอร์เดียวกัน
ซึ่งจะทำให้การทำงานง่ายและสะดวกรวดเร็วขึ้น
นอกจากนัน้นกัออกแบบและพฒันา Flash ยงันยิม
สร้าง Layer folder เพือ่การจดัเกบ็ Layer
ทีมี่อ็อบเจก็ตใ์น Layer นัน้คลา้ยคลงึกนั

ดงัรปูประกอบเปน็การจดัเรยีงลำดบัของ Layer
ทีด่ทีำใหง้า่ยและสะดวกตอ่การใชง้าน Flash

กราฟกิชนดิ Bitmap
ภาพกราฟกิชนดิ Bitmap เปน็ภาพทีเ่กดิจากการนำจดุสเีลก็ทีเ่รยีกวา่พกิเซล (Pixel) มารวมกนั

ความละเอยีด ความสวยงามของภาพจงึขึน้อยูก่บัจำนวนความละเอยีดของ Pixel

ชนดิของกราฟฟกิทีใ่ช้งานใน Flash

ข้อดี
ภาพชนิดนี้สามารถแสดงรายละเอียดได้ไกล้เคียงกับภาพจริง
สามารถแสดงภาพที่มีจำนวนสีหลากหลายสีได้ดี
ข้อเสีย
ภาพชนิดนี้จะมีขนาดใหญ่ตามความละเอียดของภาพเพราะต้อง
ใช้จำนวนพกิเซลเพิม่ขึน้ตามความละเอยีดของภาพ นอกจากนัน้
เมื่อนำภาพมาขยายจะทำให้ภาพมีความชัดเจนลดลงหรืออาจ
เห็นเป็นจุดสีแตกอยู่ในภาพ

เมื่อขยายจะพบว่าภาพจะแตก



กราฟกิชนดิ Vector
ภาพกราฟกิชนดิ Vector เกดิจากการคำนวณทางคณติศาิสตรเ์ขา้มาชว่ยสรา้งเสน้และลวดลายตา่ง ๆ

คอมพวิเตอรจ์ะทำการเกบ็คา่รายละเอยีดเกีย่วกบั อ็อปเจค็นัน้ ๆ วา่มลัีกษณะอยา่งไร

ข้อดี
ภาพชนดินีป้รับหรอืยอ่ขนาดไดต้ามตอ้งการ โดยไมมี่
ผลตอ่ความละเอยีดของภาพแตอ่ยา่งไร นอกจากนี้
ภาพชนดินีย้งัมขีนาดไฟลเ์ลก็กวา่ Bitmap (ในกรณทีีก่ราฟกิ
แบบ Vector มีจำนวนสใีนภาพมากอาจทำใหภ้าพมขีนาด
ใหญไ่ด)้

ข้อเสีย
ภาพชนิดนี้ไม่เหมาะสมกับการนำเสนอภาพในลักษณะที่มี
ปริมาณสมีากเชน่ ภาพถา่ย

เมื่อขยายจะพบว่าภาพไม่จะแตก

Pen Tool เปน็อปุกรณช์นดิหนึง่ใน Flash เพือ่ใช้สร้างภาพแบบกราฟกิชนดิ Vectorโดยมกีารใชง้าน
ดงันี้

การใช ้Pen Tool เพ่ือสรา้งกราฟกิแบบ Vector

๐ การวาดเสน้ตรงใหท้ำการคลกิที ่         เพือ่ทำการเลอืกเครือ่งจากนัน้ใหค้ลกิ 1 ครัง้เพือ่
กำหนดจดุเริม่ตน้และคลกิอกี 1 ครัง้เพือ่กำหนดจดุตอ่ไปเพือ่สร้างเปน็เสน้ตรง

คลิก คร้ังแรกเพือ่
กำนหดจุดเริ่มต้น

คลิก
ครั้งที่สองในทิศทาง
ท่ีเราต้องการสร้างเส้น

ในกรณทีีเ่ราตอ้งการวาดเสน้ใหมท่ีไ่ม่ตอ่เนือ่งกบัเสน้เดมิทีเ่รา ใหเ้รากลบัไปคลกิที ่           1ครัง้
หรอืในขณะทีอ่ยูใ่นเครือ่งมอื Pen Tool ใหก้ด Ctrl คา้งไวแ้ลว้คลกิเมาสบ์ริเวณพืน้ทีท่ำงาน (Stage) 1ครัง้



๐ การวาดเสน้โคง้ขณะทีอ่ยูใ่นการทำงานของ Pen Tool ใหค้ลกิทีจุ่ดเริม่ตน้หนึง่ครัง้และยงัไมป่ล่อย
เมาส์และให้ลากเมาส์เพื่อเป็นการกำหนดทิศทางและลักษณะของเส้นโค้ง จากนั้นให้คลิกที่จุดที่สองเพื่อสร้าง
และทำการลากเมาส์เพื่อกำหนดทิศทางและลักษณะของเส้นโค้งเส้นโค้ง

คลิกครั้งแรกเพื่อกำหนด
จุดเริม่ตน้

ในขณะที่ทำการคลิกครั้งแรก
ไม่ปล่อยเมาส์และลาก
เมาส์ไปยังทิศทางที่ต้องการ
เพ่ือกำหนดลักษณะของเส้นโค้ง

คลิกครั้งที่สองและ
ในขณะที่ทำการคลิกนั้น
ไม่ปล่อยเมาส์และลาก
เมาส์ไปยังทิศทางที่ต้องการ
เพ่ือกำหนดลักษณะของเส้นโค้ง

๐ ในการใชง้าน Pen Tool เพือ่สร้างเสน้โคง้นัน้บางครัง้
เราอาจไม่ได้เส้นโค้งตามที่ต้องการในครั้งแรกซึ่งเราก็สามารถ
แกไ้ขไดโ้ดยใชเ้ครือ่งมอื            Subselection Tool เพือ่การ
ปรับแตง่และแกไ้ข

หากทำการใช ้Subselection Tool  คลิกและลากโดย
ปกติจะเป็นการปรับตำแหน่งของเส้นทั้งสองด้าน
หากเราต้องการปรับเพียงด้านเดียวก็ให้ทำการกด
ปุ่ม Alt คา้งไวเ้วลาคลกิ

๐ ในกรณทีีเ่ราตอ้งการวาดเสน้ตอ่จากเสน้เดมิทีมี่อยูแ่ลว้ใหเ้ราคลกิทีเ่สน้เดมิของเรากอ่น
จากนั้นให้เราคลิกที่จุดที่เราต้องการจะวาดภาพต่อ



ปกต ิFlash จะตัง้คา่ Drawing Preferences ใหเ้ราเปน็คา่มาตรฐานแตเ่ราสามารถทำการเปลีย่น
แปลงคา่เหลา่นีไ้ดเ้พือ่ใหใ้ช้งานของเรางา่ยและสะดวกมากยิง่ขึน้โดยการใชค้ำสัง่ Edit > Preferences >
Drawing และเปลีย่นแปลงคา่ตามรปูภาพประกอบ

การตัง้คา่ Drawing Preferences

ลักษณะของ Shape ใน Flash
การวาดภาพใน Flash นัน้เมือ่เราวาดรปูดว้ยเครือ่งมอืตา่ง ๆ เรากจ็ะไดรู้ปทรง Shape

ซ่ึงประกอบดว้ย Stroke และ Fill
๐ เสน้ขอบ Stroke : เปน็โครงรา่งของรปู
๐ ส่วนทีเ่ปน็พืน้รปู Fill : พืน้ทีภ่ายในเสน้ของ

Fill

Stroke

เราสามารถเปลีย่นส ีStroke และ Fill
ไดโ้ดยการคลกิเลอืก Shape นัน้ ๆ และเปลีย่นสี
Stroke และ Fill ไดท้ี ่ Properties Inspector



ใน Property Inspector มีรายละเอยีดใหเ้รากำหนดดงันี้

การกำหนดรายละเอยีดของรปูทีว่าด

สี Fill

สี Stroke
ขนาดของ Stroke

กำหนดความ
เรียบของเส้น

ลักษณะของ Stroke

ใช้กำนหดการแสดงรูปแบบของเส้น
เวลาแสดงผล Movie เม่ือมีการ Zoom in
และ Zoom Outกำหนดขนาดและ

ตำแหน่ง

กำหนดลกัษณะของ Stroke เอง

กำหนดลักษณะ
ปลายเส้น

กำหนดลักษณะ
จุดเชื่อมต่อระหว่าง
เสน้

การใช ้Selection Tool
Selection Tool เปน็เครือ่งมอืทีใ่ช้ในการเลอืกและการปรบัแตง่รปูทรง

๐ การปรบัแตง่รปูทรง เมือ่เราเลอืกเครือ่งมอื Selection Tool และทำการคลกิทีข่อบของ Shape เรา
สามารถทำการปรบัแตง่ Shape ของเราไดต้ามทีเ่ราตอ้งการ

คลิกทีข่อบของ Shape และลากจะเปน็การปรบั
แตง่ลกัษณะของ Shpe ซ่ึงโดยปกต ิจะเปน็การ
ปรับแตง่ ในลกัษณะรปูทรงโคง้ ซ่ึงหากเราตอ้ง
การปรบัแตง่ใหเ้ปน็รปูทรงเหลีย่ม ใหก้ดปุม่
Alt ค้างเอาไว้

กด Alt คา้งไวจ้ะทำใหเ้ปน็การปรบัแตง่ในลกัษณะรปูทรงเหลีย่ม



การใช ้Line Tool
Line Tool เปน็เครือ่งมอืทีใ่ช้ในการเลอืกวาดเสน้ตรงมวีธิกีารในการใชง้านดงันี้
๐ การวาดเสน้ตามปกตใิหค้ลกิที ่       และทำการคลกิเมาสค์า้งไวเ้พือ่กำหนดจดุเริม่ตน้ ตอ่มาลาก

เมาสไ์ปยงัตำแหนง่ทีต่อ้งการ แลว้ปลอ่ยเมาสก์จ็ะไดเ้สน้ตรงตามแนวทีเ่ราลากเมาส์
เมือ่เรากด Shift คา้งไวใ้นขณะทีว่าด

จะทำให้เราสามารถวาดเส้นตรงที่ทำมุม
0, 90,45 องศาได้

0ํ

45 ํ90 ํ

Line Tool มี Options เพิม่เตมิคอืเมือ่คลกิทีปุ่่ม           จะเปน็การ Snap to Objects ทีไ่ดส้ร้างไวก่้อน
หน้านั้นทำให้สามารถวาดเส้นได้อย่างต่อเนื่อง

การใช ้Pencil Tool
Pencil Tool เปน็เครือ่งมอืทีใ่ช้ในการเลอืกวาดเสน้ทีเ่ปน็รปูทรงอสิระเหมอืนกบัการวาดภาพดว้ย

ดินสอมีวิธีการใช้งานดังนี้
๐ ใหค้ลกิที ่        และทำการลากเมาสไ์ปตามทศิทางและรปูทรงทีต่อ้งการวาด

Pencil Tool มี Options ในการวาดดงันี้
๐ เมือ่วาดเสน้ทีมี่ลักษณะใกลเ้คยีงกบัเสน้ตรงหรอืเปน็มมุโปรแกรมจะ
ทำการปรบัลักษณะเสน้ใหมี้ลักษณะเสน้ตรง  แตถ่า้เสน้ทีว่าดมลัีกษณะ
ใกลเ้คยีงกบัเส้นโคง้โปรแกรมจะปรบัเส้น ใหมี้ลักษณะเปน็เสน้โคง้
๐ เม่ือวาดเลว้โปรแกรมจะทำการปรบัเส้นให ้มีลักษณะราบเรยีบยิง่ขึน้
๐ จะไมมี่การปรบัแตง่ ผู้วาดลากเสน้แบบใดกจ็ะไดเ้สน้แบบนัน้

การใช ้Oval Tool

Oval Tool เปน็เครือ่งมอืทีใ่ช้ในการเลอืกวาดวงกลมและวงรี
โดยหากตอ้งการวาดใหเ้ปน็วงกลม ใหก้ด Shift คา้งไวใ้นคณะทีว่าด
และหากตอ้งการใหว้งกลมทำการวาดจากจดุศนูยก์ลางใหก้ด Alt คา้งไว้
ในขณะที่ทำการวาด

ปกติจะวาดจาก
จุดเริม่ตน้ทีเ่ริม่
คลิกวาด

จุดเริม่ตน้

กด Alt ค้างไวจ้ะ
วาดจากจุดศูนย์กลาง



การใช ้Rectangle Tool
Rectangle Tool เปน็เครือ่งมอืทีใ่ช้ในการวาดรปูส่ีเหลีย่มผนืผา้หรอืส่ีเหลีย่มจตัรัุสโดยมวีธิกีารใชง้าน

ดงันี้
๐ ใหค้ลกิที ่        และทำการลากเมาสไ์ปเพือ่กำหนดลกัษณะรปูส่ีเหลีย่มทีเ่ราตอ้งการจะวาด

โดยหากเราตอ้งการทีจ่ะวาดรปูส่ีเหลีย่มจดัตรัุสใหก้ด Shift คา้งไวใ้นขณะทีว่าด นอกจากนัน้การกด Alt
ค้างไว้ในขณะที่วาดจะเป็นการวดรูปสี่เหลี่ยมโดยกำหนดจุดเริ่มต้นจากจุดศูนย์กลางของสี่เหลี่ยมที่วาด

Rectangle Tool มี Options เพิม่ดังนี้
Set Coner Radiaus ใช้ปรับรูปทรงสีเ่หลีย่มทีว่าดใหมี้มุมโคง้มนตามคา่ทีเ่รากำหนด โดยคา่ยิง่มาก

มุมก็จะยิ่งมีความโค้งมาก

การใช ้PolyStar Tool
PolyStar Tool เปน็เครือ่งมอืทีใ่ช้ในการวาดรปูหลายเหลีย่มและรปูดาว
๐ ใหค้ลกิที ่        และทำการลากเมาสไ์ปเพือ่รูปทรงหลายเหลีย่มหรอืรูปดาวตามทีเ่ราตอ้งการ

PolyStar Tool มี Options เพิม่ซ่ึงจะไมเ่หมอืนกบั Tool อ่ืน ๆ เพราะ Options ของ PolyStar Tool จะไปอยูท่ี่
Property Inspector โดยมกีารกำหนดคา่เพิม่เตมิดงันี้

กำหนดลักษณะให้เป็นรูปหลายเหลี่ยมหรือ
รูปดาว

กำหนดจำนวนด้านของรูปหลายเหลี่ยมหรือ
จำนวนแฉกของรูปดาว

กำหนดความลึกของแฉกของรูปดาว
มีค่าระหวา่ง  0 และ 1
โดยค่าน้อยจะให้มุมแหลมมากขึ้น

0.00                        1.00



การใช ้Brush Tool
Brush Tool เป็นเครือ่งมอืสำหรบัวาดภาพระบายส ีBrush Tool มีลักษณะคลา้ยกบั Pencil Tool

แตจ่ะแตกตา่งกนัตรงที ่Brus Tool วาดภาพออกมาเปน็ Fill ส่วน Pecil Tool วาดภาพออกมาเปน็ Stroke
โดยมีวิธีการใช้งานดังนี้

๐ ใหค้ลกิที ่           และทำการลากเมาสไ์ประบายสตีามทีต่อ้งการ โดยสทีีร่ะบายออกมาจะมลัีกษณะ
เป็น Fill
Brush Tool มี Options เพิม่เตมิดังนี้

กำหนดขนาดของ Brush

กำหนดเสน้ของ Brush

ระบายสีตามปกติ
ระบายสลีงในบรเิวณทีเ่ป็น Fill
ระบายสีใช้ล่างออบเจ็กต์ที่มีอยู่แล้ว
ระบายสีเฉพาะบริเวณที่เลือก
ระบายสีเฉพาะบริวเณที่เราทำการ
คลิกเมาส์ครั้งแรก

การใช ้Ink Bottle Tool
Ink Bottle Tool เปน็เครือ่งมอืสำหรบัเทสใีหเ้สน้ขอบ หรอืเรยีกวา่ Stroke

โดยมีวิธีการใช้งานดังนี้
๐ ใหค้ลกิที ่          เพือ่ทำการเทสใีห ้Stroke (วตัถทุีเ่ทสลีงไปไดด้ว้ย Ink Bootle Tool ตอ้งเปน็

Stroke เทา่นัน้)

การใช ้Paint Bucket Tool
Paint Bucket Tool เป็นเครือ่งมอืเทสใีหพ้ื้นรูปหรือเรียกวา่ Fill
๐ ใหค้ลกิที ่         เพือ่ทำการเทสใีห ้Fill (วตัถทุีเ่ทสลีงไปไดด้ว้ย Paint Bucket Tool ตอ้งเปน็

Fill เทา่นัน้)
Paint Bucket Tool มี Options เพิม่เตมิดังนี้

ให้เติมสีในวัตถุปิดเท่านั้น
ให้เติมสีในวัตถุเปิดน้อย
ให้เติมสีในวัตถุเปิดปานกลาง
ให้เติมสีในวัตถุเปิดมาก

โดยปกต ิPaint Bucket Tool
จะอนุญาตให้เทสีได้กับรูปทรงปิดเท่านั้น
หากเราต้องการเทสีให้กับรูปทรงเปิดเรา
ตอ้งเลอืก Options เพือ่กำหนดขนาด
ความกว้างของการเปิดของรูปทรง



การใช ้Eraser Tool
Eraser Tool เปน็เครือ่งมอืลบเสน้ Stroke หรอืสีพืน้ Fill มีวธิกีารใชง้านดงันี้
๐ ใหค้ลกิที ่         จากนัน้ใหท้ำการคลกิและลากเมาสบ์ริเวณทีต่อ้งการจะลบ

Eraser Tool มี Options เพิม่เตมิดังนี้

ลบภาพแบบปกต ิ ซ่ึงภาพจะหายไปตามแนวทีล่บ
ลบภาพเฉพาะบรเิวณทีเ่ป็น Fill
ลบภาพเฉพาะบรเิวณทีเ่ป็น Stroke
ลบภาพเฉพาะบริเวณที่เราได้เลือกไว้
ลบภาพเฉพาะบริเวณที่เราทำการคลิกครั้งแรก

Faucet ใช้สำหรบัลบพืน้ทีท่ัง้หมด
ทีท่ำการคลกิลงไป ใช้ไดท้ัง้กบั
Fill และ Stroke

กำหนดขนาดและลักษณะของหัวแปรง

การใช ้Eyedroper Tool
Eyedropper Tool เปน็เครือ่งมอืทีใ่ช้ดสีูของของวตัถตุา่ง ๆ ทัง้ในและนอก Stage

เพื่อนำมาเก็ไว้ใช้งานต่อไปมีวิธีการใช้งานดังนี้
๐ ใหค้ลกิที ่         จากนัน้นำ Eyedroper Tool ไปคลกิบรเิวณทีเ่ราตอ้งการทีจ่ะดดูสมีาใชง้าน

โดยหลงัจากเราทำการเลอืกสเีสรจ็แลว้ เครือ่งมอืของเราจะถกูเปลีย่นเปน็           Paint Bucket Tool
โดยอตัโนมตั

ความเขา้ใจพืน้ฐานเกีย่วกบัออบเจก็ต์

การท่ีจะปรับแต่งรายละเอียดของออบเจ็กต์บนเสตจเราต้องมีความเข้าใจ
พื้นฐานเบื้องต้นเกี่ยวกับออบเจ็กต์เสียก่อนเพื่อที่เราจะ
สามารถจัดการปรับแต่งออบเจ็กต์ได้ตามที่เราต้อง



การเลอืกออบเจก็ต์
ปกตเิวลาทีเ่ราทำการเลอืกออบเจก็ตโ์ดยเครือ่งมอื Selection Tool เราสามารถเลอืกได้

1 ออบเจก็ตโ์ดยการคลกิเมาส ์และหากเราตอ้งการเลอืกออบเจก็ตม์ากกวา่ 1 ออบเจกต ์ใหเ้รากด Shift พรอ้ม
กับการคลิกเลือกออบเจ็กต์ชิ้นที่เราต้องการเลือกต่อไป

นอกจากนัน้เรายงัสามารถทำการเลอืกออบเจก็ตต์า่ง ๆ
ได้ด้วยการลากเมาส์ครอบออบเจ็กต์ที่เราต้องการ

ลากเมาส์ครอบออบเจ็กต์ที่เราต้องการเลือก

หากเราดบัเบิล้คลกิทีอ่อบเจก็ตท์ีมี่ทัง้ Stroke และ Fill จะเปน็การเลอืกทัง้ Stroke และ Fill ซ่ึงวธิกีารนี้
จะเปน็การสะดวกในการเลอืกออบเจก็ตท์ีมี่ทัง้ Stroke และ Fill ในครัง้เดยีว

การซอ้นกนัของรปูทรงใน Flash

๐หากเราวาดออบเจก็ตท์ีมี่แต ่Fill ซ้อนกนัโดย สี Fill ของออบเจก็ตท์ัง้สองมสีีเหมอืนกนั จะทำใหพ้ืน้ที่
ของออบเจ็กต์ทั้งสองถูกรวมเข้าด้วยกัน

นำมารวมกัน ผลที่ได้คือออบเจ็กต์ถูกรวมกัน

๐หากเราวาดออบเจก็ตท์ีมี่แต ่Fill ซ้อนกนัโดย สี Fill ของออบเจก็ตท์ัง้สองมสีีตา่งกนั จะทำใหพ้ืน้ที่
ของออบเจก็ตท์ัง้สองถกูแยกออกจากกนั และบรเิวณสเีดมิทีถ่กูทบัจะหายไป

นำมารวมกัน ผลที่ได้คือออบเจ็กต์ถูกแยกจากกัน
และบริเวณสีเดิมที่ถูกทับจะหายไป



๐หากเราวาดออบเจก็ตท์ีเ่ปน็ Stroke ทบัลงบน  Fill จะเปน็การแยกออบเจก็ตท์ีเ่ปน็ Fill ออกจากกนั
ซึ่งวิธีการนี้จะมีประโยชน์มากในการตัดหรือแยกออบเจ็กต์ออกจากกัน

๐ หากเราตอ้งการนำออบเจก็ตท์ีมี่ สี Fill หรอื Stroke แตกตา่งกนัมาซอ้นกนัโดยไมใ่ห้
ออบเจก็ตดักนั เราตอ้งใชค้ำสัง่  Modify > Group เพือ่รวมออบเจก็ตข์องเราเขา้ไวด้ว้ยกนั หรอืกด Ctrl + G

ออบเจ็กต์ท่ีมีสีต่างกันสามารถวางทับ
กนัไดโ้ดยไมต่ดัออกจากกนั ดว้ย
การใชค้ำสัง่ Group

การ Group ออบเจก็ตเ์ข้าด้วยกนั

การ Group ออบเจก็ตเ์ปน็การรวมออบเจก็ตต์า่ง ๆ เขา้ไวด้ว้ยกนัมขีัน้ตอนและประโยชนใ์นการใชง้าน
ดงันี้

ความรูพ้ื้นฐานเบือ้งตน้เกีย่วกบั Group
๐ ออบเจก็ทีถ่กูสัง่ Group ล่าสดุจะถกูสัง่ใหม้าอยูบ่นสดุ
๐ หากเราทำการวาดภาพหรอืระบายสเีพือ่สร้างออบเจก็ใหม่
ลงบน Layer ทีมี่ออบเจก็เดมิทีถ่กูสัง่ Group อยู่
ออบเจก็ใหมท่ีเ่ราวาดจะอยูด่า้นลา่ง ออบเจก็ทีเ่ราสัง่
Groupไว้เสมอ

ทำการระบายสีลงบน
ออบเจก็เดมิทีถ่กู Group
ผลที่ได้คือสีที่ระบายจะไปอยู่
ดา้นลา่งออบเจก็ทีถ่กู Group



๐ หาเราตอ้งการแกไ้ขออบเจก็ทีถ่กู Group
อยูใ่หท้ำการดบัเบิล้คลกิที ่ออบเจก็นัน้เพือ่เขา้สูโ่หมด
แกไ้ข Group

แสดงสถานะให้รู้ว่าอยู่ใน
โหมดการแกไ้ข Group

กำหนดสโีดยใชพ้าเนล Color Mixer และพาเนล Color Swatches

Color Mixer เปน็พาเนลทีใ่ช้ในการผสมสแีละการไลสี่ตามทีต่อ้งการซึง่มรีายละเอยีดดงันี้

เลือกสี Stroke
เลือกสี Fill

เลือกประเภทของสี

เปล่ียนสีโดยการ
เปล่ียนคา่ตวัเลข

เปล่ียนสีโดยการ
คลิกลากสีต

เปลี่ยนค่าความ
โปร่งใสของสี

เปลี่ยนค่าสีโดยพิมพ์เลขฐาน
16

เปลีย่นสใีหก้ลบัเปน็คา่มาตรฐาน ดำ/ขาว

เลอืกไมใ่ส่สีใหกั้บ Stroke หรอื Fill

สลับสีระหวา่ง Stroke กับ Fill

สีเดมิ
สีใหม่



ใน Color Mixer เราสามารถเลอืกประเภทของสทีีใ่ช้ไดด้งันี้

None      Solid Linear         Radial     Bitmap

สำหรบัสีแบบ Linear หรือ Radial
ยงัม ีคา่ใหเ้ราสามารถกำหนดสำหรบัการไลสี่ไดอี้ก

คลิกเลือกที่พอยเตอร์จากนั้นให้คลิกเลือกสีที่ต้องการ
เปลี่ยนเพื่อเปลี่ยนสีในการไล่โทนสี

หากเราต้องการเพิ่มพอยเตอร์ในการไล่สีก็ให้เราคลิก
บริเวณแถบสีเพื่อสร้างพอยเตอร์ใหม่

หากต้องการลบให้คลิกที่พอยเตอร์และลากออก
ไปนอกบริเวณแถบสี

เราสามรถปรับแต่งลักษณะการไล่สีแบบ
ละเอยีดไดโ้ดยใชเ้ครือ่งมือ Fill Transform Tool



Color Swatches เป็นเสมอืนจานสใีหเ้ราเลอืกเปลีย่นสี ่Stroke และ Fill นอกจากนี้
เรายงัสามารถจดัการเกบ็คา่สตีา่ง ๆ ตามทีเ่ราตอ้งการ

สำหรบัเปล่ียนสแีบบ Solid

สำหรับเปลี่ยสีแบบ
Linear, Radial, Bitmap

๐ หากเราใชเ้ครือ่งมอื          Eyedropper Tool คลกิเลอืกสทีีไ่ม่มีใน Color Swatches สีทีเ่ราเลอืกนัน้
จะถกูจัดเกบ็ใน Color Swatches โดยอตัโนมติั

๐ ในขณะทีเ่ราเลอืกสใีดสหีนึง่อยูห่ากเรานำเมาสไ์ปวางบรเิวณพืน้ทีว่า่งใน Color
Swatches (บริเวณทีเ่ป็นสีเทา) เมาสข์องเราจะเปลีย่นเปน็รูป      และหากเราทำการคลกิเมาส์
ก็จะเปน็การนำสทีีเ่ลอืกในขณะนัน้มาจดัเกบ็ใน Colour Swatches

การนำภาพแบบ Bitmap เข้ามาใชง้าน

Flash สามารถจดัการกบัภาพแบบ Bitmap ไดห้ลากหลายชนดิ โดยหากเราตอ้งการใชง้านกใ็หเ้ราใช้
คำสัง่ File > Import >Import to Stage เพือ่นำภาพมาไวบ้น Stage ในทนัทเีลย
หรอืเราอาจใชค้ำสัง่ File > Import >Import to Library เพือ่นำภาพมาไวใ้น Library กอ่นจากนัน้เราคอ่ยนำ
ภาพเข้ามาใช้ในภายหลัง

การกำหนดคณุสมบัติของรูปภาพแบบ Bitmap
เพือ่ไม่ให ้Flash มีช้ินงานใหญเ่กนิไป เมือ่เรานำภาพแบบ Bitmap เขา้มาใน Flash แล้วเมือ่เราทำการ

Export Movie โปรแกรมจะทำการบบีอัดภาพของเราโดยอตัโนมตัซ่ึิงถอืเปน็คา่มาตราฐาน  ซ่ึงจะใชก้บัภาพ
ทุกภาพ

นอกจากนั้นเรายังสามารถเลือกที่จะจัดการบีบอัดภาพของเราแต่ละภาพได้เองซึ่งสามารถทำได้ดังนี้



๐ ใหท้ำการดบัเบิล้คลกิทีรู่ปนัน้ ๆ ในพาเลท Library กจ็ะปรากฎ หนา้ตา่งมาใหเ้ราตัง้คา่การบบีอัด
๐ ใหท้ำการคลกิขวาทีรู่ปนัน้ ๆ และเลอืก Properties.. กจ็ะปรากฎ หนา้ตา่งมาใหเ้ราตัง้คา่การบบีอัด

หากต้องการตั้งค่าการบีบอัดเองให้ทำการยกเลิก
Options นี้ ตั้งค่าการบีบอัดตามที่เราต้องการ

คลกิที ่Test หากตอ้งการดผูลการ
บีบอัด

บริเวณพืน้ที ่Preview การบบีอัดของเรา
ซ่ึงเราสามารถคลิกและลากเมาส์เพ่ือเล่ือนดูรายละเอียดได้

การแกไ้ขภาพ Bitmap
ปกตเิวลาทีเ่รานำภาพแบบ Bitmap เขา้มาใน Flash เราจะไมส่ามารถทำการแกไ้ขหรอืปรับแตง่คา่

ตา่ง ๆ ได ้(เราทำไดเ้พยีงแตก่ารยอ่/ขยาย) ซ่ึงหากเราตอ้งการปรบัแตง่แกไ้ขภาพแบบ Bitmap เพิม่เตมิโดยใช้
คำสัง่ Modify > Break Apart  หรอืกด Ctrl +B

เมือ่ใช้คำสัง่ Break Apart
แล้วเราจะสามารถปรับแต่งแก้ไขภาพได้มากยิ่งขึ้น



การเปลีย่นภาพแบบ Bitmap ใหเ้ป็น Vector
เราสามารถเปลีย่นภาพแบบ Bitmap ให้เป็น Vector ได้ดว้ยคำสัง่

Modify > Bitmap > Trace Bitmap... และกำหนดคา่ในการแปลงภาพดงันี้

Color threshold : เปน็การกำหนดคา่ระหวา่ง 1 ถงึ 500 ในการแปลงภาพแตล่ะพกิเซลทีอ่ยูต่ดิกนัจะถกูนำมา
เปรยีบเทยีบกนั ถา้คา่สคีวามแตกตา่งของสทีัง้สองมคีา่มากกวา่สทีีเ่รากำหนด จะถอืวา่พกิเซลทัง้สองเปน็
พกิเซลเดยีวกนั ดงันัน้ถา้เรากำหนดคา่สงู กจ็ะทำใหภ้าพของเรามรีายละเอยีดนอ้ย (ขนาดไฟลเ์ลก็)
Minimum Area : กำหนดคา่ 1 ถงึ 100 เพือ่ระบจุำนวนพกิเซลโดยรอบ ทีจ่ะถกูนำมาพจิารณาการกำหนดสี
Curve Fit : กำหนดวา่ตอ้งการใหข้อบมคีวามราบเรยีบมากเพยีงใด
Corner Threshold : กำหนดวา่จะใหรั้กษามมุแหลมในภาพไวม้ากนอ้ยเพยีงใด

การสรา้งข้อความ
การสรา้งขอ้ความใน Flash มีอยูส่องลกัษณะดงันี้

๐ การสรา้งขอ้ความแบบอสิระ
เป็นวิธีการสร้างข้อความแบบพื้นฐาน
มีวธิกีารคอืใหค้ลกิที ่        จากนัน้
ให้คลิกที่บริเวณที่ต้องการพิมพ์
และทำการพิมพ์ข้อความ

ให้สังเกตการพิมพ์ข้อความแบบอิสระบริเวณ
ขอบมุมจะมีสัญลักษณะเป็นวงกลม

การพมิพข์อ้ความแบบอสิระเหมาะสำหรบัขอ้
ความทีมี่ความยาวไมม่ากนกั เชน่ หวัขอ้
หรอื ขอ้ความทีเ่ปน็ปุม่ Link

หากเราทำคลิกที่วงกลมบริเวณมุมของกล่องข้อความและ
ลากไป ก็จะเปน็การเปลีย่นขอ้ความแบบอสิระ เปน็ขอ้ความ
แบบกำหนดขอบเขต (วงกลมจะเปลีย่นเปน็ส่ีเหลีย่ม)
ถ้าหากเราต้องการเปลี่ยนค่ากลับคืนให้ทำการดับเบิ้ลคลิกที่
ส่ีเหลีย่ม (ส่ีเหลีย่มจะกลบัเปน็วงกลม)



การสรา้งขอ้ความแบบกำหนดขอบเขต
การสรา้งขอ้ความใน Flash มีอยูส่องลกัษณะดงันี้

๐ การสรา้งขอ้ความแบบกำหนดขอบเขต
มีวธิกีารคอืใหค้ลกิที ่        จากนัน้ทำการคลกิและ
ลากเมาส์เพื่อกำหนดขอบเขตที่ต้องการพิมพ์
และพิมพ์ข้อความในขอบเขตที่เลือกไว้

ให้สังเกตการพิมพ์ข้อความแบบกำหนดขอบ
เขตขอบมุมจะมีสัญลักษณะเป็นสี่เหลี่ยม

การพิมพ์ข้อความแบบกำหนดขอบเขต
เหมาะสำหรับข้อความที่มีความยาวมาก
หรือข้อความที่ทำการพิมพ์จากโปรแกรม
อ่ืนและนำเขา้มาใน Flash โดยคำสัง่
Paste  เชน่ ขอ้ความทีเ่ป็น Content
ของเวบ็ไซต์

หากเราทำคลิกที่วงกลมบริเวณมุมของกล่องข้อความและ
ลากไป กจ็ะเปน็การยอ่และขยายกลอ่งขอ้ความซึง่จะสง่ผล
กับข้อความข้างในด้วย

การกำหนดรูปแบบของข้อความ

กำหนดลักษณะของ
ข้อความที่จะสร้าง กำหนดรูปแบบของ

ตัวอักษร

กำหนดขนาด
ของตัวอักษร

กำหนดสี
ของตัวอักษร

กำหนดลักษณะ
การจัดข้อความ

ตัวหนา
ตัวเอียง

กำหนดระยะห่าง
ระหว่างตัวอักษร

กำหนดให้เป็นตัวยก
หรือตัวห้อย กำหนดรูปแบบ

การ Render
ตัวอักษร

กำหนดให้มีการปรับช่องไฟตัวอักษรแบบอัตโนมัติ



กำหนด Link ใหกั้บขอ้ความโดยมตีวัเลอืกเพิม่เตมิดงันี้
_ blank เปดิหนา้เพจใหมข่ึน้มา
_ parent แสดงบนหนา้เพจเดมิโดยลบหนา้เดมิออก
_ self แสดงในเพจหรอืเฟรมเดยีวกนัทีแ่สดงขอ้ความ
_ top แสดงเวบ็เพจในเฟรม top

กำหนดย่อหน้า
กำหนดระยะห่างระหว่างบรรทัด
กำหนดระยะห่างขอบซ้าย
กำหนดระยะห่างขอบขวา

สร้างตัวอักษรในแนวนอน
สร้างตัวอักษรในแนวตั้งเรียงจากซ้ายไปขวา
สร้างตัวอักษรในแนวตั้งเรียงจากขวาไปซ้าย

ใหใ้ช้ตวัอกัษรทีมี่ในเครือ่งของ User ทำใหข้นาดไฟล ์Flash
มีขนาดเลก็ แตห่าก User ไม่มี Font ชนดินัน้กไ็ม่สามารถอา่นได้

ทำใหต้วัอกัษรกลายเปน็ Bitmap

ทำใหตั้วอักษรคมและชดัเจนสำหรบังาน animation
เหมาะสำหรบัตัวอักษรทีมี่การทำ animation

ทำใหต้วัอกัษรคมและชดัเจนสำหรบัการอา่น เหมาะสำหรบั
ตวัอกัษรทีเ่ปน็ Content ของ Website



ซิมบอลและอินสแตนซ์
ซิมบอล (Symbol) คอืการนำออบเจก็ตท์ีเ่ปน็ภาพกราฟกิ ปุ่มกด หรอืมูฟวี ่มากำหนดเปน็ตน้แบบ เพือ่

นำไปใชเ้ปน็สว่นประกอบในชิน้งาน โดย Symbol ทีถ่กูสรา้งขึน้จะถกูจดัเกบ็ไวใ้น Library
เราไมส่ามารถนำ Symbol มาใชง้านบน Stage ไดโ้ดยตรง แตเ่ราจะนำเพยีงสำเนาของ Symbol หรอื

ทีเ่ราเรยีกวา่ อินสแตนซ ์(Instance) มาใช ้ซ่ึงหนึง่ Symbol สามารถ นำมาใชง้านเปน็ Instance ไดห้ลายอนั
บน Stage โดยแตล่ะ Instance อาจถกูปรบัแตง่รายละเอยีด เชน่ ขนาด สี ฯลฯ แตท่ัง้หมดกม็าจาก Symbol

Symbol ตน้แบบเมือ่ถกูสรา้งจะถกูจดัเกบ็
ไว้ใน Library

เมือ่เรานำ Symbol จาก Library มาใชง้านบน
Stage เราจะเรยีก Symbol ทีเ่รานำมาวางไวบ้น
Stage วา่ Instance ซ่ึง Instance เปน็เพยีง
สำเนาของ Symbol เราสามารถเรยีก Instance
มาใชง้านบน Stage ไดอ้ยา่งไมจ่ำกดัและถา้เรา
ทำการปรบัเปล่ียน Instance ในลักษณะ
ต่าง ๆ ก็จะไมส่่งผลตอ่ Symbol

 Instance
 Instance

 Instance

การเปลีย่นแปลง Instance
จะไม่มีผลกับ Symbol

Symbol Instance

การเปลีย่นแปลง Symbol
มีผลกับ instance

Symbol Instance



การนำ Instance มาใชง้านซำ้ ๆ กันบน Stage มีขอ้ดคีอืจะชว่ยให ้File Movie ของเรามขีนาดเลก็ลง
กวา่ การทีเ่ราทำการสรา้งรปูทรงแบบเดยีวกนัขึน้มาใหมบ่น Stage

การสรา้ง Symbol
เราสามารถสรา้ง Symbol ไดห้ลายวธิดีงันี้

กรณท่ีี 1 : การสรา้ง Symbol จาก ออบเจก็ต์ท่ีมีอยูแ่ลบ้น Stage

วธิทีี ่1 : คลกิเลอืก ออบเจก็ตท์ีเ่ราตอ้งการ
เปลีย่นใหเ้ปน็ Symbol แลว้ใชค้ำสัง่
Modify > Convert to Symbol หรอืกดปุม่
F8 ท่ีคีย์บอร์ด

วธิทีี ่2 : คลกิเลอืก ออบเจก็ตท์ีเ่ราตอ้งการ
และคลกิขวาแลว้เลอืก Convert to Symbol...

ใหใ้ช้คำสัง่ Insert >New Sybol...
หรอืกดปุม่ Ctrl + F8 ทีค่ยีบ์อร์ด

กรณีท่ี 2 : การสร้าง Symbol ข้ึนมาใหม่

หลงัจากนัน้จากมหีนา้ตา่ง เปดิขึน้มา ใหเ้ราตัง้ชือ่ และเลอืกประเภทของ Symbol ตามทีเ่ราตอ้งการ

ตัง้ชือ่

เลือกประเภทของ
Symbol



การแกไ้ข Symbol
ใหเ้ราทำการ ดบัเบิล้คลกิที ่Instance ของ Symbol นัน้ ๆ บน Stage  หรอืทำการดบัเบิล้คลิกทีไ่อคอน

ของ Symbol นัน้บนพาเลท Library

เราอาจเรยีกการเขา้ไปแกไ้ข Symbol ในลกัษณะ
อยา่งนีว้า่ Edit In Pace ซ่ึงเราสามารถทำการแกไ้ข
หรอืจะทำการเพิม่ Layer ปรับแตง่คา่ตา่ง ๆ ไดเ้หมอืนกบั
ออบเจก็ต ์หนึง่ ใน Stage

โดยเราอาจกลา่วไดว้า่ Symbol กเ็หมอืนกบัการนำ
ไฟล ์Flash มาซอ้น ไฟล ์Flash อีกทหีนึง่ เพราะใน Symbol
จะม ีTime line และ Layer เป็นของตวัเอง

คลกิทีน่ีเ่พือ่กลบัสู่ Stage

การเปลีย่น Instance ใหก้ลบักลายเปน็ ออบเจก็ต์

เปน็การเปลีย่น Instance ใหก้ลบักลายเปน็กราฟกิธรรมดา
โดยสามารถทำไดโ้ดยเลอืกคำสัง่ Modify > Break Apart  หรอื
กดคยี ์Ctrl B ทีเ่ปน้คยีบ์อร์ด

การทำสำเนาใหกั้บ Symbol
การทำสำเนาใหก้บั Symbol เปน็การคดัลอก

Symbol โดยสามารถทำไดโ้ดยการคลกิเมาส์
ทีบ่ริเวณไอคอนของ Symbol ในพาเลท Library
และเลอืก Duplicate

จากนัน้ใหต้ัง้ชือ่ใหมใ่หก้บั Symbol ทีเ่รา
ทำการทำสำเนา



การนำ Instance มาใชง้าน
หลงัจากทีเ่ราไดส้ร้าง Symbol มาใชง้านแลว้ เราสามารถ นำ Instance ของ Symbol ทีเ่ราไดส้ร้าง

มาใชง้านได ้โดยใหเ้ราคลกิทีไ่อคอนของ Symbol บนพาเนล Library และลากมายงั Stage

คลกิและลากมายงั Stage

การปรบัสีให ้Instance
ขอ้ไดเ้ปรยีบอกีอยา่งในการใชง้าน Instance กค็อืหากลองสงัเกตดใูหด้ทีี ่Property Inspector ของ

Instance จะมีตัวเลอืกเพิม่ขึน้มาใหเ้ราไดป้รับแตง่สีเพิม่เตมิ ซ่ึงตวัเลอืกนีจ้ะไม่มีในออบเจก็ตแ์บบธรรมดา
ท่ีไม่ได้เป็น Instance

ตัวเลือกปรับแต่งสีที่เพิ่มขึ้นมา

Symbol Movie Clip
หากเราทำการเปลีย่น ออบเจก็ต ์ใหก้ลายเปน็ Movie Clip เราจะเหน็วา่ใน Property Inspector ของ

Instance จะมีตัวเลอืกเพิม่เตมิคือ เราสามารถใส ่Filters และทำการ Blend ให้กับ Instance ของเราได้



การใชง้าน Filters
ฟลิเตอรค์อื รูปแบบพเิศษใชใ้นการตกแตง่ออบเจก็ต ์เราสามารถใส ่Filters ใหก้บั Instance ของ

Movie Clip, Button และ ตวัอกัษร โดยเราเรยีกใช ้Filters ผ่าน Property Inspector ในแทบ็ Filters
รายละเอยีดของ Filters ตา่ง ๆ มีดงันี้

Drop Shadow : เปน็ลกัษณะการใสเ่งาใหก้บัวตัถุ

ปรับความเบลอในแนวตั้ง/แนวนอน เลือกสี

กำนดคุณภาพ
ของเงา ความเข้ม

ของเงา

องศาของเงา

ระยะห่างระหว่าง
ระหว่างวัตถุ/เงา

กำหนดให้ส่วนที่
เป็นพื้นของวัตถุ
โปร่งใส

เงาด้านในวัตถุ

แสดงเฉพาะเงา
ซ่อนวัตถุ

Blur : เปน็ลกัษณะการปรบัวตัถใุหเ้บลอ (ไม่คมชดั)

Glow : เปน็การสรา้งแสงรศัมจีากขอบของวตัถุ



Bevel : เปน็การสรา้งวตัถใุหมี้ความนนู
เลือกสีเงาของวัตถุ

เลือกสีความสว่างของวัตถุ

เลือกว่าจะให้
นนูจากขา้งใน Inner
นนูจากขา้งนอก Outer
นูนทัง้ในและนอก Full

Gradient Glow : เป็นการไลเ่ฉดสใีห้กับสีรัศมขีองวตัถุ ปรับไล่เฉสี

Gradient Bevel : เปน็การไลเ่ฉดสใีหเ้งามคีวามนนูขึน้มา

Adjust Color : เปน็การปรบัแตง่ส ีความคมชดั ความมดื - สวา่งใหก้บัวตัถุ



การบันทกึ Filters :
เราสามารถทำกบับันทกึคา่การปรบัแตง่ Filters
ของเราไวเ้พือ่การสะดวกตอ่การเรยีกใช ้ในครัง้ตอ่ ๆ
ไปไดโ้ดยเลอืกคำสัง่ Presets > Save As ...

การใชง้าน Blend
การ Blend หรอื Blending เปน็การตกแตง่ภาพใหมี้การแสดงสสัีนแตกตา่ง ไปจากภาพปกต ิโดย

อาศยัระหวา่งสทีีซ้่อนกนั ใหมี้ความกลมกลนืจนกลายเปน็ภาพทีมี่สีสันใหม ่โดยมคีำศพัท ์3 คำทีเ่ราควรรู้
ในการใชง้าน Blending Mode 8nv

1.Base Color เป็นสีของรปูทีเ่ป็นแบค็กราวดห์รือสีเดมิ
2.Blend Color เปน็สขีองรปูทีน่ำมาซอ้นทบัแบค็กราวด์
3.Result Color เปน็ผลของสขีองภาพทีไ่ดท้ำการ Blending

โหมดตา่ง ๆ ของ Blend

Base Color Blend Color

Nomal : โหมดปกต ิจะไมมี่การเปลีย่นแปลงคา่ใด ๆ

Layer : โหมดนีต้อ้งใชง้านรว่มกบั Alpha และ Erase



Darken : เปน็การเปลีย่นสเีฉพาะพืน้ที ่ถา้พืน้ทีไ่หนมคีวามมดืมากกวา่
พื้นที่นั้นจะไม่มีการเปลี่ยนสี

Mutiply : ผสมสีโดยการเพิม่สีของ Blend Color ลงไปน Base Color
จะได้ภาพที่มืดขึ้น

Lighten : ส่วนของ Base Color ทีมื่ดกวา่ Blend Color จะถกูแทนดว้ย
Blend Color แตส่่วนทีส่วา่งกวา่จะไมมี่การเปลีย่นแปลง

Screen : ทำให ้Blend Color ซีดหรอืจางลง

Overlay : สีของ Base Color จะไม่เปล่ียน แตจ่ะถกูสะทอ้นดว้ยคา่ความ
สวา่งทีเ่กดิจากสขีอง Blend Color

Hard light : ผลทีไ่ดจ้ะเหมอืนกบัการฉายแสงสปอรต์ไลทม์าทีภ่าพ โดย
ถ้าสีของ Blend Color มีความสวา่งมากกวา่สีเทา 50 % Result Color ท่ีได้
จะดสูว่างขึน้ ถ้า Blend Color มีความมดืมากวา่ 50 % Result Color ท่ีได้
จะมีความมืดมากขึ้น



Add : เพิม่ความสวา่งใหกั้บ Blend Color ซ่ึงจะทำใหภ้าพดนุู่มนวล

Difference : เปน็การแสดงคา่สทีีเ่กดิจากการผลตา่ง ของคา่ความสวา่ง
ระหวา่ง Base Color และ Blend Color สีไหนมคีา่ความสวา่งมากกวา่
Result Color กจ็ะออกไปทางสนีัน้ ซ่ึงถา้สใีดสหีนึง่เปน็สขีาว Result Color
ก็จะเปน็อกีสีหนึง่ทนัท ีและถา้สีใดเปน็สีดำ Result Color จะไมมี่การเปลีย่น

Subtract : ใหผ้ลตรงกนัขา้มกบั Add โดยจะลดทอนความสวา่งของ Blend
Color ใหมื้ดลง

Invert : เปล่ียน Blend Color ใหต้รงกนัขา้มกบั Base Color ทัง้ภาพ

ในส่วนของ Alpha และ Erase จะมวีธิกีารใชง้านทีแ่ตกตา่งจากโหมดการ Blend อ่ืน ๆ ดงันี้

1. ให้นำภาพ Bitmap วางบน Stage
จากนัน้ใหเ้ปลีย่นเปน็ Symbol แบบ
Movie Clip



2. ดบัเบิล้คลิกที ่Instance ของ Movie Clip ทีเ่ราสรา้งขึน้มา
ใหมเ่พือ่เขา้ไปแกไ้ข Movie Clip

3. สร้าง Layer ขึน้มาใหม ่1 Layer จากนัน้ใหว้าดสีเ่หลีย่ม
ขึน้มาทบัรูป Bitmap ของเรา

4. ใช้ Eraser Tool          ลบบริเวณรปูรถยนต ์ใน Layer
ทีเ่ราไดส้ร้างขึน้มาใหม ่(อาจทำการปรบัลดคา่ Alpha
เพือ่ใหม้องเหน็ Layer ดา้นลา่งพือ่ใหส้ะดวกตอ่การ
ใช้ Eraser Tool ลบ  จากนัน้จงึคอ่ยปรบัคา่กลบัคนื)

5. ทำการเปลีย่นสีเ่หลีย่มทีเ่ราพึง่ทำการลบไปแลว้
ให้กลายเปน็ Symbol แบบ Movie Clip จากนัน้
ใส่ Filters  > Blur

7. ทำการเปลีย่นโหมดการ Blend ของสีเ่หลีย่มของเราใหเ้ปน็
Erase



8. คลกิทีน่ี ่เพือ่กลบัไปทำงานยงั Stage หลกั

9. ทำการเปลีย่น โหมดการ Blend  ใหเ้ปน็
Layer กจ็ะเหน็ผลดงัภาพ คอืบริเวณทีถ่กู
Eraser Tool ลบออกไปจะปรากฎภาพรถ
ส่วนภาพในบริเวณที่ไม่ได้ลบออกไปจะหายไป

ในขัน้ตอนที ่7 หากเราทำการเปลีย่นโหมดการ
Blend ของสีเ่หลีย่มใหเ้ป็น Alpha
ก็จะได้ค่ากลับกันดังรูป

Frame คอืช่องแสดงภาพแตล่ะจังหวะทีเ่มือ่นำมาแสดงตามลำดบัอยา่งรวดเรว็ จะทำใหเ้กดิภาพ
เคลือ่นไหวซึง่ Frame ทีถ่กูแสดงบน Stage คอืเฟรมทีต่วัเลือ่น Play head ช้ีอยู่

Frame และหลกัการสรา้งภาพเคลือ่นไหว

Play head



ช่อง Frame บน Time Line จะบ่งบอกถงึประเภทของเนือ้หาใน Frame น้ันโดยแสดงลกัษณะที่
แตกต่างกันดังนี้

ความหมายของ Frame แตล่ะประเภทบน Time Line

Keyframe เปลา่ทีไ่ม่มีการไล ่ออบเจก็ตไ์ว้

Keyframe ทีมี่การใส ่ออบเจก็ตไ์ว้

Frame เปล่าทีไ่ม่มีการไล ่ออบเจก็ตไ์ว้

Keyframe เดีย่วในเฟรมทัง้หมดจะเปน็ตาม Key Frame แรกทีด่า้นซา้ยสดุ และมกีรอบ
สี่เหลี่ยมที่เฟรมสุดท้ายที่จะแสดงภาพหนึ่ง

การสรา้งภาพเคลือ่นไหวแบบ Frame by Frame

เปน็การระบขุอ้มูลทกุ Frame ดว้ยตวัเอง ไดแ้ก ่ออบเจก็ต ์ในเฟรม และรายละเอยีดตา่ง ๆ ของออบ
เจก็ตน์ัน้ ๆ ไดแ้กต่ำแหนง่ขนาด มุมหมนุ โทนส ีการสรา้งภาพเคลือ่นไหวดว้ยวธิกีารนีใ้ช้เวลามาก เพราะตอ้ง
กำหนดองคป์ระกอบของ ออบเจก็ตต์า่ง ๆ ดว้ยตวัเอง ทีล่ะ Frame

เริม่ตน้ชิน้งานมเีพยีง Frame เดยีวในทกุ ๆ Layer

ทำการใส ่Keyframe
ให้กับทุก ๆ Layer

ปรับแตง่องคป์ระกอบตา่ง ๆ ตามทีต่อ้งการ
นอกจากนั้นเรายังสามารถนำ
ออบเจ็กต์อื่นมาแทนออบเจ็กต์เดิมของเราด้วย

ตา, แวน่, คิว้ ถกูปรบัตำแหนง่

ปากและหน้าถูกเปลี่ยนเป็นออบเจ็กต์อื่น



คลกิขวาทีต่ำแหนง่ทีต่อ้งการเพิม่ Frame และเลอืกคำสัง่
๐ Insert Keyframe หรอืกดคยีลั์ด F6 (หรอืคลกิเลอืกตำแหนง่เฟรม
และเลอืกคำสัง่ Insert > Timeline > Keyframe

๐ Insert Blank Keyframe หรอืกดคยีลั์ด F7 เพิม่คยีเ์ฟรมวา่ง
(หรอืคลกิเลอืกตำแหนง่เฟรม และเลอืกคำสัง่ Insert >Timeline>
Blank Keyframe)

การเพิม่ Frame

๐ เราสามารถ Insert Keyframeใหกับัหลาย ๆ Layer พร้อมกนั
ไดโ้ดยการกด Shift และทำการเลอืก Layer ทีเ่ราตอ้งการจะใส่
Keyframe และเลอืกคำสัง่ Insert > Timeline > Keyframe

การกด Shift และทำการเลอืก Layer

การจดัการกบั Frame

กอ่นทีเ่ราจะทำสิง่ใด ๆ ใหก้บั
Frame เราจะตอ้งเลอืกเฟรมนัน้ ๆ
เสยีกอ่นโดยใหเ้ราทำการคลกิ Frame นัน้ ๆ
ไดเ้ลยและถา้หากเราตอ้งการเลอืกหลาย ๆ
เฟรมพรอ้มกนัใหก้ด Shift คา้งไว้
ในขณะเลือก

 Shift คา้งไวแ้ละทำการคลกิถา้ตอ้งการ
เลอืกหลาย ๆ Frame พร้อมกนั

การแทรก Frame และ Keyframe

๐ ถา้ตอ้งการเพิม่ Frame แทรกระหวา่งกลางหลงัจากไดมี้การกำหนด Keyframe แลว้ใหค้ลกิขวาที่
ตำแหนง่ทีเ่ราตอ้งการเลอืกและใชค้ำสัง่ Insert Frame หรอืกด F5

๐ ถา้ตอ้งการเพิม่ Keyframe แทรกระหวา่งกลางหลงัจากไดมี้การกำหนด Keyframe
แลว้ใหค้ลกิขวาทีต่ำแหนง่ทีเ่ราตอ้งการเลอืกและใชค้ำสัง่ Insert Keyframe หรอืกด F6



การลบ Frame และ Keyframe

๐ ถ้าตอ้งการลบ Frame หรือ
Keyframe ใด ๆ บน Timeline ใหค้ลกิขวาที่
ตำแหนง่ ทีเ่ราตอ้งการเลอืกและใชค้ำสัง่
Remove Frame หรือกด Shift + F5

การ Copy Frame และ Keyframe

๐ เราสามารถทำการ Copy Frame/Keyframe ได้โดยการคลกิเพือ่เลือกตำแหนง่ของ Frame/
Keyframe ทีเ่ราตอ้งการ Copy และทำการคลกิขวาจากนัน้เลอืก Copy Frame

คลกิเลอืก Frame ทีต่อ้งการ และคลกิขวาเลอืกคำสัง่
Copy Frames

จากนั้นให้เราทำการเลือกบริเวณเฟรมที่เราจะวางและทำการ
คลกิขวาและเลอืกคำสัง่ Paste Frame

การยา้ยตำแหนง่ Keyframe

เราสามารถทำการยา้ยตำแหนง่ของ Keyframe ไดโ้ดยทำการเลอืก Keyframe
ที่เราต้องการและทำลากมาส์ไปยังตำแหน่งที่ต้องการ

คลิกและลากไปยังตำแหน่งที่ต้องการ



การสรา้งแอนเิมชัน่ดว้ย Shape Tween
Shape Tween เปน็การสรา้งภาพเคลือ่นไหวโดยแปลงจากรปูทรงหนึง่ไปอกีรูปทรงหนึง่ โดยโปรแกรม

Flash จะคำนวน Frame แทรกระหวา่งทัง้สอง Frame ใหเ้อง
โดยวธิกีารสรา้ง Shape Tween มีดงันี้

1. ทำการสรา้งรปูทรงวงกลมลงในเฟรมแรก เพือ่กำหนด Shape เร่ิมตน้

สร้างวงกลมให ้Frame แรก

2. ไปทีเ่ฟรม 15 และทำการ Insert Keyframe
และลบรูปวงกลมทึ้งไปจากนั้นสร้างรูปดอกไม้
ขึน้มาเพือ่กำหนดใหเ้ปน็ Shape ทีเ่ราตอ้งการ
เปลี่ยน

สร้างรูปดอกไม้ขึ้นมา

3. กลับไปคลกิที ่Frame แรกจากนัน้ไป
เลอืกที ่Properties และเลอืก Tween
เป็นแบบ Shape

กลบัไปคลกิที ่Frame แรก

เลือก Shape Tween



ออบเจก็ตแ์รก ออบเจ็กต์ที่สองFlash คำนวณ
Frame ระหวา่งกลางให้

ในบางครัง้เมือ่เรา ทำการแอนเิมชัน่แบบ Shape Tween เราจะพบวา่เราจะไมไ่ด ้Shape ตามทีเ่รา
ตอ้งการ ซ่ึงเราสามารภแกไ้ขแอนเิมชัน่ใหไ้ดต้ามแบบทีเ่ราตอ้งการไดโ้ดยใชค้ำสัง่ Modify > Shape > Add
Shape Hint

ไม่ได้แอนิแมชั่นตามที่เราต้องการ

ใช้คำสัง่ Shape Hint เพือ่แกไ้ข



โดยวธิกีารใชง้าน Shape Hint นัน้ใหเ้ราเลอืกที ่Frame แรกจากนัน้ใหใ้ช้คำสัง่ Modify > Shape > Add
Shape Hint จากนัน้ใหน้ำ Shape Hint ไปวางยงัตำแหนง่มมุทีเ่ราตอ้งการจะเปน็จดุยดึในการเปลีย่นรปูทรง
จากนัน้ใหค้ลกิเพือ่เลอืก Frame ทีส่อง และลาก Shape Hint ไปวางยงัตำแหนง่มมุของ ออบเจก็ตท์ีส่อง

ใช้คำสัง่ Modify > Shape > Add
Shape Hint ใน Frame ท่ี 1 และนำ
Shape Hint ไปวาง ยังมุมของออบเจก็ต์
ท่ีแรก

ไปยัง Frame ท่ีสอง และนำ Shape Hint
ไปวางยังมุมของออบเจ็กต์ที่สอง

เทคนคิเพิม่เตมิเกีย่วกบัการทำ Shape Tween
๐ การทำ Shape Tween ใน 1 Layer เราควรมอีอบเจก็ตเ์พยีง 1 ออบเจก็ต์
๐ ในการทำ Shape Tween นัน้ ออบเจก็ตค์วรมลัีกษณะคลา้ยกนั เชน่ หาก ออบเจก็ตเ์ริม่ตน้มี

เพยีง Fill ออบเจก็ตท์ีเ่ราตอ้งการใหเ้ปลีย่นแปลงเรากค็วรจะใหมี้แต ่Fill ไม่ควรม ีStroke

ออบเจ็กตเ์ร่ิมตน้มเีพยีงแต ่Fill

ออบเจก็ตท์ีต่อ้งการเปลีย่นแปลงกค็วรจะมแีต ่Fill



เราสามารถสรา้งแอนเิมชัน่แบบ Motion Tween โดยมขีัน้ตอนดงัตอ่ไปนี้
1. สร้าง ออบเจก็ต ์ใด ๆ กไ็ดใ้น Frame แรก โดยถา้ออบเจก็ตข์องเรามหีลายชิน้ประกอบกนัเรากค็วรสัง่
Group ใหเ้ปน็ชิน้เดยีวกนัหรอืเปลีย่น ออบเจก็ตใ์หเ้ปน็ Symbol เสยีกอ่น

การสรา้งแอนเิมชัน่ดว้ย Motion Tween

สร้าง ออบเจก็ต ์ใด ๆ ก็ไดใ้น Frame แรก
ถา้ออบเจก็ต ์มีหลายชิน้ใหเ้ปลีย่น ออบเจก็ต์
ใหเ้ปน็ Symbol กอ่น หรอืจะทำการ Group
ออบเจ็กต์ไว้ก็ได้

2. ไปยงั Frame ทีเ่ราตอ้งการกำหนดขอบเขตความยาวของ แอนแิมชัน่ของเราจากนัน้ใชค้ำสัง่
Insert Keyframe

ใช้คำสัง่ Insert Keyframe

3. ทำการเปลีย่นตำแหนง่และขนาดของ ออบเจก็ตข์องเราใน Keyframe ทีเ่ราพึง่สรา้งขึน้มาใหม่

ทำการเปลี่ยนตำแหน่งและขนาดของออบเจ็กต์

ออบเจ็กต์เฟรมแรก
ออบเจ็กต์เฟรมที่เราต้องการเปลี่ยนแปลง



4. กลับไปคลกิที ่Frame แรกจากนัน้ไป
เลอืกที ่Properties และเลอืก Tween
เป็นแบบ Motion

กลบัไปคลกิที ่Frame แรก

เราจะเห็นออบเจ็กต์ของเราทำ
แอนิเมชั่นตามที่เรากำหนดไว้

Tween : เลือกรูปแบบของ Tween ซ่ึงมี 2 ชนิดคอื Motion Tween และ Shape Tween
Ease : กำหนดอตัราเรว็ของการเคลือ่นไหวในแตล่ะเฟรม

๐ ถา้กำหนดคา่เปน็ 0 การเคลือ่นไหวจะเรว็คงที่
๐ ถา้กำหนดคา่เปน็ลบ (สังเกตคำวา่ In) การเคลือ่นไหวจะเริม่ตน้ชา้ และเรง่ความเร็วในชว่งทา้ย
เรียกวา่ Easing in
๐ ถา้กำหนดคา่เปน็บวก (สังเกตคำวา่ Out) การเคลือ่นไหวจะเริม่ตน้เรว็ และลดความเรว็ลงใน
ช่วงทา้ย เรยีกวา่ Easing Out

Scale : คลกิทีต่วัเลอืกนี ้ถา้ตอ้งการใหมี้การเปลีย่นแปลงขนาดของออบเจก็ตโ์ดยพจิารณาจาก Keyframe
เร่ิมต้น และ Keyframe สุดทา้ย

Rotate : เปน็การกำหนดการหมนุของวตัถุ

รายละเอยีดของ Tween ทีเ่ราสามารถปรบัแตง่ได้



๐ None ไม่ให้หมุนออบเจก็ต์
๐ Auto หมนุออบเจก็ตไ์ปในทศิทีเ่คลือ่นไหวสัน้ทีสุ่ด
๐ Clock Wise (CW) หมนุออบเจก็ตต์ามเขม็นาฬกิา
๐ Counter Clockwise (CCW) หมนุออบเจก็ตท์วนเขม็นาฬกิา

Orient to Path : กำหนดใหอ้อบเจก็ตว์ิง่ตามเสน้ Path โดยใหห้มนุไปตามทศิทางทีเ่ราตอ้งการ
Syn : ใช้สำหรบัปรับอัตราเรว็ของการเคลือ่นไหวใหต้รงกนัระหวา่ง Timeline หลกักบั Timeline ยอ่ย ๆ
Snap : ใหอ้อบเจก็ตย์ดึเสน้ไกดต์ลอดเวลา

เทคนคิเพิม่เตมิเกีย่วกบัการทำ Motion Tween
๐ การทำ Motion Tween นัน้ยิง่ Keyframe เร่ิมตน้กบั Keyframe สุดทา้ยของเรามคีวามแตกตา่ง

กนัมากเพยีงใด กจ็ะมผีลกบัการเคลือ่นไหวของเรามากเทา่นัน้ เชน่ ถา้ Keyframe เริม่ตน้ออบเจก็ตมี์ขนาดเลก็
มาก Keyframe สุดทา้ยออบเจก็ตมี์ขนาดใหญม่ากกจ็ะทำให ้แอนเิมชัน่ของเราเปน็การเปลีย่นแปลงจากเลก็
ไปใหญ่มาก

๐ ถา้ออบเจก็ตข์องเรามหีลายชิน้ประกอบกนัเรากค็วรสัง่ Group ใหเ้ปน็ชิน้เดยีวกนัหรอืเปลีย่น
ออบเจก็ตใ์หเ้ปน็ Symbol เสยีกอ่น

๐ เราสามารถทำแอนเิมชัน่การเปลีย่นสไีดไ้ด้
ใช้ Color : ที ่Properties

ใช้งานปุม่ Swap... ช่วยสรา้งงานแอนเิมชัน่

1. ใหค้ลกิที ่Frame ทีส่องและคลกิขวาเลอืกคำสัง่ Insert Keyframe

หากคณุไดเ้ตรยีมสรา้งออบเจก็ตต์า่ง ๆ ทีจ่ะสรา้งงานแอนเิมชัน่ของคณุเอาไว ้ใน Library แลว้คณุ
สามารถใชปุ่้ม Swap ช่วยในการเปลีย่น ออบเจก็ตบ์น Stage กบั ออบเจก็ใน Library ได้



2. คลกิเลอืกออบเจก็ทีต่อ้งการเปลีย่น
คลกิทีปุ่่ม Swap ใน Properties จากนัน้เลอืก
รูปที่ต้องการเปลี่ยน

เราสามารถทำตามขั้นตอนนี้
ซ้ำเพือ่สร้างงานแอนเิมชัน่ได ้เชน่ใน
กรณตีวัอยา่งนีค้อืเปลีย่นปากไปเรือ่ย ๆ
ก็จะได้แอนิเมชั่นการพูดของตัวละคร

การทำใชง้าน Motion Guide เพ่ือสรา้งงานแอนเิมชัน่
เราสามารถสรา้งเสน้ขึน้มา เปน็ Guide ใหอ้อบเจก็ตข์องเราวิง่ตามเสน้ Guide ของเราไดโ้ดยมวีธิกีาร

ดังต่อไปนี้

1. สร้างเสน้ขึน้มา 1เส้นเพือ่เป็นเสน้ Guide (เส้น
ควรเป็นเส้นแบบเปิด

2. สร้างออบเจก็ตข์ึน้มา 1 ช้ินและใหอ้ยูค่นละ
Layer กบั เสน้ของเรา (ถา้ออบเจก็ตมี์หลายชิน้
ใหส่ั้ง Group เอาไวห้รอือาจเปลีย่นใหเ้ปน็ Symbol)

3. ทำการคลกิขวาที ่Layer เส้นและเลอืกคำสัง่ Guide



4. ลาก Layer เสน้เขา้ไปอยูใ่น Layer Guide

5. ทำการเพิม่ Key Frame ใหก้บั Layer
ทั้งสองเพื่อกำหนดความยาวของแอนิเมชั่น

6. ดใูหแ้นใ่จวา่            Snap เปดิใชง้านอยู่
จากนัน้ไปที ่Frame แรกของ Layer
ออบเจ็กต ์และเลือ่นออบเจก็ตข์องเราไปยงั
บริเวณจุดเริ่มต้อนของเส้น

7. ใหค้ลกิเลอืกที ่Frame สุดทา้ย
จากนัน้เลือ่น ออบเจก็ตไ์ปยงั
จุดสิ้นสุดของเส้น



8. คลกิเลอืก Frame แรกของ
Layer ออบเจก็ตจ์ากนัน้คลกิขวา
และเลือก

9. หากคลกิเลอืก Frame แรกของ
Layer และสงัเกตดจูะเหน็ที่
Properties จะมตีวัเลอืกเพิม่เตมิ
ดงันี้

Orient to Path : กำหนดใหอ้อบเจก็ตว์ิง่ตามเสน้ Path โดยใหห้มนุไปตามทศิทางทีเ่ราตอ้งการ
Syn : ใช้สำหรบัปรับอัตราเรว็ของการเคลือ่นไหวใหต้รงกนัระหวา่ง Timeline หลกักบั Timeline ยอ่ย ๆ
Snap : ให้ออบเจก็ตย์ดึเสน้ไกดต์ลอดเวลา



Botton
ปุ่มกด (Botton) เปน็ Symbol ประเภทหนึง่ทีท่ำใหผู้้ใช้สามารถโตต้อบกบัช้ินงานทีส่ร้างขึน้ได ้โดยเรา

สามารถนำปุ่มกดมาใช้งานประยุกต์ร่วมกับคำสั่งได้อย่างหลากหลาย

เฟรม Up เปน็สถานะปกตขิองปุม่กด คอื เปน็สถานะเริม่ตน้
ของปุม่ เมือ่ผู้ใช้ยังไมไ่ดท้ำการโตต้อบใด ๆ

เฟรม Over เป็นสถานะเมื่อผู้ใช้เลื่อนตัวชี้เมาส์มาวางอยู่เหนือ
ปุ่ม

เฟรม Down เป็นสถานะที่เมื่อผู้ใช้ทำการคลิกบนปุ่ม
เฟรม Hit ผู้ใช้จะไมส่ามารถเหน็สถานะนีข้องปุม่ แตใ่ช้สำหรบั

กำหนดขอบเขตการทำงานของปุ่ม

วิธกีารสรา้งปุ่มกด
1) ใหเ้ราทำการคลกิเมาสข์วาทีบ่ริเวณวตัถใุด ๆ กไ็ดบ้น Stage จากนัน้เลอืก Convert to Symbol

2) เลือกชนดิของปุม่ใหเ้ป็นแบบ Button

3) หากตอ้งการแกไ้ขปุม่เพิม่เตมิใหท้ำการดบัเบิล้คลกิ
ทีปุ่่ม เรากจ็ะเหน็วา่เราสามารถกำหนดสถานะของปุม่
4 สถานะ ตามทีไ่ดก้ลา่วไปแลว้ขา้งตน้

4) ทำการคลกิทีบ่ริเวณสถานะ Over
จากนัน้ใหท้ำการคลกิเมาสข์วาและเลอืก Insert Keyframe
ขั้นตอนต่อไปให้ทดลองทำการเปลี่ยนสีของปุ่มเป็นสีอื่น
(สีทีไ่ม่ใช่สีเดยีวกบัสถานะ Up)



4) ใหค้ลกิทีบ่ริเวณสถานะ Over จากนัน้ให้
ทำการคลกิขวาและเลอืก Insert Keyframe
ขั้นตอนต่อไปให้ทดลองทำการเปลี่ยนสีของปุ่มเป็นสีอื่น
(สีทีไ่ม่ใช่สีเดยีวกบัสถานะ Up และ Over)

5) ในสถานะของ Hit เราโดยปกตแิลว้หากเราไมท่ำการวาดรปูใด ๆ  ลงไป ของเขตของปุม่กจ็ะถกู
กำหนดจาก Shape เริม่แรกของปุม่ในสถานะ Up

หากเราทำการ Test Movie กจ็ะพบวา่เมือ่เรานำเมาสไ์ปวางบนบรเิวณปุม่กด ตวัชีเ้มาสจ์ะเปลีย่นเปน็
รูปมือ แสดงใหเ้ราทราบวา่สามารถทำการคลกิเมาสเ์พือ่เกดิผลตามทีผู้่สร้างชิน้งานไดก้ำหนดไว้

เราสามารถทำการทดสอบการทำงานของปุ่มได้โดยไม่ต้อง
ทำการ Test Movie ดว้ยการเลอืกคำสัง่  Control > Enable Simple
Buttons  แตห่ากเราใชค้ำสัง่นีเ้ราจะไมส่ามาถทำการแกไ้ขปุม่ได้
เพราะเวลาทีเ่ราจะคลกิเมาสเ์พือ่ใหไ้ปทำการแกไ้ขปุม่ ตวัชีเ้มาส์
จะเปลีย่นเปน็รปู มือ ทำใหไ้ม่สามารถเขา้ไปแกไ้ขได้

โปรแกรม Flash ได้เตรยีมปุ่มแบบ
สำเรจ็รูปไวใ้หเ้ราไดใ้ช้งาน โดยเราสามารถ
เรียกใช้ได้โดยใช้คำสั่ง
Window > Common Libraries >
Buttons

เราสามารถเลอืกรูปแบบของปุม่แบบตา่ง ๆ ได้ตาม
ทีเ่ราตอ้ง หากเราพอใจปุม่ในรปูแบบใหก้ใ็หเ้ราทำการคลกิ
เมาสค์า้งไวแ้ละลากปุม่นัน้ลงบน Stage



การทำงานเกีย่วกบั File เสียง
โปรแกรม Flash ไม่สามารถสรา้ง File เสยีงขึน้มาไดเ้อง ดงันัน้หากเราตอ้งการใชง้านเสยีงใน Flash

เราตอ้งทำการนำเสยีงเขา้มายงั Flash โดยใชค้ำสัง่ File > Import > Import to Library

เราสามารถนำไฟลเ์สยีงประเภทตา่ง ๆ
เข้ามาใช้งานได้ดังนี้
๐ WAV (ใช้ไดก้บั Window เทา่นัน้)
๐ Aiff (ใช้ได้ท้ังกบั Window และ Mac แตห่ากเราตอ้งการ
ใช้งานกบั Window เราตอ้ง Install โปรแกรม Quick Time
เสียก่อน)
๐ MP 3 (ใช้ได้ท้ักับ Window และ Mac)

การใชง้าน File เสียง
การทีเ่ราจะใชง้าน File เสยีงใด ๆ กอ่นอืน่เราตอ้ง

ทำการ Import File เสยีงมายงั Library ของเราเสยีกอ่นโดย
ใช้คำสัง่ File > Import > Import to Library

จากนัน้ใหค้ลกิที ่Frame ใด ๆ ทีเ่ราตอ้งการใสเ่สยีง (เราควรทำการแยก Layer เสยีงใหเ้ปน็ 1 Layer
ตอ่ 1 เสยีง เราไมค่วรนำเสยีงมาวางใน Layer ทีมี่วตัถวุางอยู ่และเราไมค่วร  ใส่เสยีงมากกวา่ 1 เสยีงใหก้บั
1 Layer) คลกิเลอืก Sound ใน Properties จากนัน้ใหเ้ลอืกเสยีงทีเ่ราตอ้งการ

๐ File เสยีงมคีวามยาว มีเวลาเปน็ของตวัเองไมเ่ชือ่มโยง หรอืไม่ไดอ้้างองิกบัเวลาบน Time Line
ดังนัน้หากไฟลเ์สียงของคณุมีความยาวกวา่ Time Line File เสียงของคณุกจ็ะเลน่ไม่จบ เพราะ Time Line
มีเวลาสัน้กวา่ File เสียงทำให ้เวลาบน Time Line หมดกอ่น File เสียง ดัง้นัน้หาก File เสียงมคีวามยาว
มากกวา่ Time Line คณุตอ้งทำการขยาย Time Line ใหย้าวขึน้เพือ่เล่น File เสียงไดจ้นจบ

การปรับแต่งเสียง
เราสามารถทำการปรบัแตง่คา่ตา่ง ๆ ใหก้บัไฟลเ์สยีงของเราไดด้งันี้

Sound แสดงชือ่ File เสยีงทีเ่ลอืก
Effect กำหนดเอฟ็เฟก็ตใ์หก้บัเสียง โดยมรูีปแบบตา่ง ๆ ดงันี้

๐ None ไม่ใช้เอ็ฟเฟก็ตใ์ด ๆ
๐ Left Chanel / Right Chanel ใหเ้สยีงออกลำโพงเฉพาะลำโพง ซ้ายหรอืขวาเทา่นัน้
๐ Fade Left to Right / Fade Right to Left ไล่เสยีงจากลำโพงซา้ยไป ลำโพงขวา หรอืไล่
เสียงจากขวาไปซ้าย



๐ Fade In ใหเ้สยีงเริม่ตน้เบา และคอ่ย ๆ ดงัขึน้
๐ Fade Out ใหเ้สียงเริม่ตน้ดงั และคอ่ย ๆ เบาลง
๐ Custom ใหเ้รากำหนดเอฟเฟค็ตา่ง ๆ ใหก้ำเสยีงเองโดยคลกิทีปุ่่ม

Sync กำหนดใหเ้ริม่ตน้ และจบการเลน่เสยีงอยา่งไร โดยมตีวัเลอืกดงันี้
๐ Event จะรอโหลดไฟลเ์สียงมาใหค้รบกอ่น จึงเริม่เลน่เสยีง และเลน่เสยีงนีจ้นจบ โดยเปน็
อิสระจาก Time Line  และอาจเลน่ตอ่แม ้Movie จะจบไปแลว้กต็าม
๐ Start จะสัง่ใหเ้ลน่เสยีงวเหมอืนกบั Event ตา่ง กนัตรงทีห่ากไฟลเ์สยีงนัน้กำลงัถกูสัง่ใหเ้ลน่
มากอ่นและยงัเลน่ไมจ่บ กจ็ะไมส่ั่งใหเ้ลน่เสยีงซอ้นกนั
๐ Stop หยดุเลน่เสยีง
๐ Steam จะเลน่เสยีงเมือ่เราโหลดไปไดแ้ล้วบางสว่น โดยโปรแกรมจะแสดงเสยีงใหสั้มพันธ์
กบัช้ินงานของ Movie ในกรณทีีเ่สยีงโหลดมาเลน่ไมท่นัภาพกจ็ะหยดุรอชัว่คราว แตใ่นกรณี
ทีภ่าพโหลดมาเลน่ไมท่นัเสยีงกจ็ะหยดุรอชัว่คราว นอกจากนัน้เสยีงแบบ Stream หยดุเลน่
เมือ่ Movie จบ และจะเลน่เสยีงตรงกบั Frame ท่ีใส่เสียงไว้
๐ Loop กำหนดจำนวนครัง้ทีต่อ้งการใหเ้ลน่เสยีงซำ้

เสยีงแบบ Event :  ใช้กำเสยีงเพลงประกอบทีต่อ้งการใชเ้ลน่แบบวนซำ้, ใช้กบัเสยีงทีใ่ส่ใหปุ่้ม
เสียงแบบ Steam :  ใช้กำหนดเสยีงในลกัษณะตวัละครกำลงัพดู

ตัวอยา่งการใชง้านเสยีง Sync

ตามปกต ิFlash จะทำการบบีอัดขอ้มูล File
เสียงแบบอตัโนมตั ิโดยจะใชค้า่มาตรฐาน กับ File เสียง
ท้ังหมด ใน Movie โดยเราสามารถตรวจสอบ และทำการ
เปล่ียนแปลงคา่การบบีอัดมาตรฐานทีใ่ช้ใหก้บั File เสยีง
ท้ังหมดไดโ้ดยใชค้ำสัง่ File > Publish Settings..

การบีบอัดข้อมูลเสียงเพื่อลดขนาดชิ้นงาน



คลกิทีปุ่่ม Set เพือ่ตัง้คา่การบบีอัด

นอกจากการตั้งค่าการบีบอัดแบบมาตรฐานแล้ว
เรายังสามารถเลือกการตั้งค่าการบีบอัดเฉพาะให้กับ
File เสยีงแตล่ะ File ได ้โดยมขีัน้ตอนดงันี้

ให้ทำการคลิกเมาส์ขวาที่ไฟล์เสียงที่
เราตอ้งการแกไ้ขที ่Panel Library และเลอืก
Properties.....

เลือกค่าการบีบอัดตามที่เราต้องการ
โดยมรีายละเอยีดในการตัง้คา่ตา่ง ๆ ดงันี้



Default ใหบี้บอัดไฟลเ์สยีงตามคา่ทีก่ำหนดไวแ้ลว้ ในหวัขอ้ง Publish Settings
ADPCM เปน็วธีิบีบอัดทีเ่หมาะสำหรบัการลดขนาดของไฟลเ์สียงสัน้ ๆ เชน่ เสียงคลกิกดปุม่
MP 3 เหมาะสำหรบับีบอัดไฟลด์นตร ีและไฟลเ์สียงทีมี่ความยาวมาก ๆ
Raw ไม่บีบอัดไฟลเ์สียงตน้ฉบบั แตเ่รากยั็งคงสามารถลดขนาดของ File ได้
Speech เหมาะกับการอัดเสียงแบบเสียงพูด

๐ ในกรณทีีเ่รามหีนว่ยความจำไมม่าก กค็วรใชไ้ฟล์เสยีงแบบ 8 บิท แทนไฟลเ์สยีงแบบ 16 บิท
๐ การกำนหด Sample Rate ใหสู้งกวา่ไฟลเ์สยีงตน้ฉบบัไม่ไดช่้วยทำใหไ้ฟลเ์สยีงมคีณุภาพดขีึน้
๐ เราไมส่ามารถกำหนดใหไ้ฟลเ์สยีงดงักวา่ไฟลเ์สยีงตน้ฉบบั แตเ่ราสามารถกำหนดใหไ้ฟลเ์สยีงเบากวา่
ต้นฉบับได้
๐ พยามนำเสยีงทีมี่อยูแ่ลว้มาใชซ้้ำ แตป่รับแตง่เสยีงโดยใชเ้อฟเฟค็ตา่ง ๆ เพือ่ใหไ้ดเ้สยีงทีห่ลากหลายขึน้

ข้อแนะนำในการใช้ไฟล์เสียง

การใชง้านไฟลวี์ดีโอ
ไฟล ์.FLV เปน็ไฟลว์ดิโีอชนดิทีถ่กูกำหนดขึน้มาใชใ้นโปรแกรม Flash ยอ่มาจากคำวา่ Flash Video ซ่ึง

Flash สามารถทำงานกบั File ชนดินีไ้ดเ้ปน็อยา่งด ีสามารถใช ้Behaviors หรอืเขยีน Script เพือ่ควบคมุการ
ทำงานของไฟล์ชนิดนี้ได้

ในโปรแกรม Flash จะบบีอัดขอ้มูลวดีโีอใหมี้ขนาดเลก็ลงโดยใช ้Codec อยู ่2 แบบทีมี่ช่ือเรยีกวา่
“On2 VP6” (ใช้กบั Flash Player 8) และ “Sorenson Spark Codec” (ใช้กบั Flash Player 7)

โดย On2 VP6 Codec นัน้จะใหค้ณุภาพวดีโีอทีเ่หนอืกวา่ Sorenson Spark Codec ทีโ่ปรแกรม Flash
รุ่นเดมิใช้ นอกจากนัน้ใชง้านไดก้บัวดีโีอแบบคอมโพสกิทีมี่อัลฟา่แชลแนลไดด้ว้ย แตก่ารบบีอัดขอ้มูลจะใช้
เวลานานกวา่ และเครือ่งของผูช้มจะตอ้งประมวลผลหนกักวา่เดมิ จึงจะสามารถเปดิไฟลว์ดีโีอได้

การนำไฟลวี์ดีโอมาใชง้านใน Flash

เรานำไฟลว์ดีโีอ (เรยีกวา่วดีโีอคลปิ) มาใชป้ระกอบมฟูวีใ่นโปรแกรม Flash ซ่ึงมอียู ่4 วธิหีลกั ดงันี้
๐ สตรีม (Stream) ไฟลว์ดีโีอ
๐ ทยอยโหลด (Progressive Download) ไฟล์วีดโีอ
๐ ฝัง (Embed) ไฟลว์ดีโีอในมฟูวี่
๐ เช่ือมโยง (Link) กบัไฟลว์ดีโีอภายนอก



สตรีม (Stream)

วธิกีารนีเ้ปน็การเผยแพรไ่ฟลว์ดีโีอหรอืไฟลเ์สยีงทีด่ทีีสุ่ด โดยเราจะนำไฟลว์ดีโีอในชิน้งานทีมี่ในเครือ่ง
ของเราไปไวบ้นเซร์ิฟเวอรท์ีต่ดิตัง้ Flash Media Server ซ่ึงเปน็ซอฟทแ์วรท์ีท่ำงานบนเครือ่งเซร์ิฟเวอรส์ำหรบั
ใหบ้ริการสือ่ วดีโีอ ภาพและเสยีง แบบเรยีลไทม ์จากนัน้ทำการอพัโหลดไปยงัเครือ่งเซร์ิฟเวอรไ์ด ้โดยจะใชค้ำ
ส่ัง Actionscript หรือ คอมโพเนน้ท ์FLV Playback ควบคมุการเลน่วดีีโอคลปีน้ี

ข้อดีของการสตรีมไฟล์วีดีโอ
๐ ไฟลว์ดีโีอจะเริม่เลน่เรว็กวา่วธิอ่ืีน ๆ
๐ การสตรมีไฟลว์ดีโีอจะใชห้นว่ยความจำ และพืน้ทีบั่นทกึขอ้มูลในเครือ่งของผูใ้ช้ทีเ่ปดิดวูดีโีอไมม่าก

นกัเพราะไมต่อ้งโหลดไฟลท์ัง้หมดมาไวใ้นเครือ่ง แตเ่ครือ่งจะทยอยโหลดมาแสดงและกล็บออกไป
๐ ทรพัยากรทางดา้นเครอืขา่ยถกูใชอ้ยา่งมปีระสทิธภิาพ เพราะวดีโีอเฉพาะสว่นทีผู้่ใช้ตอ้งการจะถกู

ส่งมาเท่านั้น
๐ ไฟลว์ดีโีอจะถกูผูใ้ช้กอ็ปป้ีไดย้าก เพราะไมไ่ดมี้การบนัทกึไฟลน์ัน้ไวใ้นเครือ่งของผูใ้ช้ เหมอืนกบั

วธิอ่ืีน ๆ ท่ีตอ้งโหลดมากอ่นถงึจะเลน่ได้
๐ วธินีีท้ำใหเ้ราสามารถเผยแพรว่ดีโีอไดแ้บบถา่ยทอดสด
ข้อเสีย
๐ วธิกีารนีมี้คา่ใชจ่้ายคอ่นขา้งสงู เพราะเราตอ้งตดิตัง้โปรแกรม Flash Media Sever ทีเ่ครือ่ง

เซร์ิฟเวอรข์องเรา หรอืตอ้งไปใชบ้ริการ Flash Viedeo Streaming Service (FVSS) จากบางเวบ็ไซต์

ทยอยโหลด (Progressive Download)
ถ้าเราไมส่มารถหา Flash Communication Server หรือ Flash Video Streaming Service มาใช ้เรา

ยงัสามารถ ใช้ไฟลว์ดีโีอจากภายนอกได ้โดยวดิกีารทยอยโหลด ซ่ึงวธิกีารนีจ้ะไมใ่หผ้ลลัพธด์เีทา่กบัการ
สตรมีไฟลว์ดีโีอ เพราะผูช้มตอ้งรอโหลดขอ้มูลวดีโีอกอ่นทีจ่ะเปดิดไูด ้แตก่จ็ะเปน็ทางเลอืกทีช่่วยใหเ้ราใชไ้ฟล์
วีดีโอภายนอกกับชิ้นงานของเราได้ แทนที่จะนำไฟล์วีดีโอมาฝังในชิ้นงานซึ่งจะทำให้ชิ้นงานของเรามีขนาด
ใหญข่ึน้

ข้อดีของการทยอยโหลดไฟล์วีดีโอ
๐ ในการเผยแพรช้ิ่นงาน ไฟลว์ดีโีอจะเริม่เลน่ทนัทหีลงัจากทีส่่วนแรกไดถ้กูโหลดเขม้าในเครือ่ง
๐ เนือ่งจากไฟลว์ดีโีอไมไ่ดถ้กูฝงัลงมาในชิน้งานเปน็ชิน้เดยีวกบัไฟลง์าน จึงไมมี่ปัญหาเรือ่งขนาดของ

ไฟล์งาน ตลอดจนไมมี่ปัญหาเรือ่งซงิโครไนซภ์าพและเสยีงไมต่รงกนั
๐ คา่ frame rate ทีเ่ลน่วดีโีอคลปิ สามารถตา่งจากคา่ frame rate ของชิน้งาน ทำใหมี้ความคลอ่งตวั

มากกว่า
ข้อเสีย
๐ ใช้เวลาในการ Down Load นาน



ฝงั (embed) ไฟลวี์ดีโอ (ชนดิ Mov, Avi, MPEG
เปน็การฝงัไฟลว์ดีโีอใหเ้ปน็สว่นหนึง่กบั Flash วธินีีเ้ปน็การนำวดีโีอมาวางบน Time Line ซ่ึงจะทำ

ใหเ้ปน็สว่นหนึง่กบัช้ินงาน เนือ่งจากไฟลว์ดีโีอมขีนาดคอ่นคา้งใหญ ่ดงันัน้จงึควรใชว้ธินีีเ้ฉพาะกบัไฟล ์วดีโีอ
ทีมี่ความยาวไมม่ากนกั (ควรยาวไมเ่กนิ 10 วนิาท)ี

ข้อดีของการฝังไฟล์วีดีโอ
๐ สามารถใสลู่กเลน่ใหก้บัไฟลว์ดีโีอไดอ้ยา่งหลากหลายเหมอืนเปน็ Movieclip ช้ินหนึง่
ข้อเสีย
๐ ไฟลว์ดีโีอทีมี่ความยาวกวา่ 10 นาท ีมักมปัีญหาเรือ่งการซงิโครไนซใ์หเ้สยีงและภาพตรงกนั
๐ ก่อนทีจ่ะเลน่วดีโีอได ้จะตอ้งโหลดไฟลมู์ฟวีเ่ปน็ SWF มาจนครบกอ่น
๐ ในกรณทีีไ่ฟลมู์ฟวีมี่ขนาดใหญ ่กจ็ะทำใหโ้ปรแกรม Flash Player ตอ้งดงึหนว่ยความจำของเครือ่ง

มาใช้งานมาก

เช่ือมโยง (Link) กบัไฟลวี์ดีโอภายนอกชนดิเป็น Quick Time (Mov)
เราสามารถนำเขา้ไฟลว์ดีโีอชนดิ QuickTime เขา้มาไดโ้ดยจะเปน็การเชือ่มโยงไปยงัไฟลว์ดีโีอนีท้ีอ่ยู่

ภายนอกชิน้งาน ซ่ึงชิน้งานนีจ้ะตอ้งแปลงเปน็ QuickTime จึงจะใชไ้ด้

ข้อแตกตา่งระหวา่ง Flash รุ่น Basic และ Flash รุ่น Professional
ในโปรแกรม Flash รุ่น Basic เราจะสามารถทำไดเ้พยีงการฝงัไฟลมู์ฟวีเ่ทา่นัน้ ไม่สามารถสตรมี หรอื

ทยอยโหลดได ้ในขณะที ่Flash รุ่น Professional จะมคีวามสามารถทัง้หมด

ข้อแนะนำในการนำภาพยนตร์มาประกอบชิ้นงาน
๐ วดีโีอทีน่ำมาแปลงเปน็ FLV นัน้ควรเปน็ตน้ฉบบั ไม่แนะนำใหน้ำวดีโีอทีผ่่านกระบวนการบบีอัดขอ้

มูลโดยวิธีอื่นแล้วมาใช้ซ้ำ
๐ วดีโีอทีจ่ะนำเขา้มาไมค่วรมทีรานสช่ัิน (เอฟเฟค็ในการเปลีย่นฉาก) ทีซั่บซ้อนมาก เพราะจะทำให้

มีปัญหาในการบบีอัดขอ้มูล และอาจทำใหไ้ฟลวี์ดีโอสะดดุ
๐ การกำหนดอตัรา Frame rate ทีเ่หมาะสมกบัวดีโีอ ถา้เปน็วดีโีอทีมี่การเคลือ่นไหวอยา่งรวดเรว็เรา

กต็อ้งใชค้า่ใชจ่้ายทีสู่งขึน้ แตถ่า้ไมจ่ำเปน็กค็วรลดอตัรา Frame rate ใหน้อ้ยลงเพราะมผีลกบัขนาดไฟลแ์ละ
เวลาในการโหลด นอกจากนัน้สำหรบัเครือ่งรุน่เกา่ไฟลว์ดีโีออาจไมท่ำงานถา้ไฟลว์ดีโีอของเรามอัีตรา Frame
rate สูง (เชน่เกนิ 15 เฟรม/วนิาท)ี

๐ ผู้ใช้ทีด่มููฟวีโ่ดยใชโ้มเดม็ธรรมดาควรกำหนดขนาดวดีโีอประมาณ 160 X 120 พิกเซล
๐ ผู้ใช้ทีด่มููฟวีโ่ดยใช ้ADSL หรอืเคเบิล้ควรกำหนดขนาดของวดีโีอประมาณ 320 X 240 พิกเซล



การใชง้าน ActionScript
ActionScript เปน็ชดุคำสัง่ทีเ่ราใชค้วบคมุวตัถหุรอืเฟรม ใหส้ามารถโตต้อบหรอืแสดงผลบางอยา่ง

เมือ่เกดิเหตกุารณ ์(จาการใส ่Action) โดยเราเรยีกเหตกุารณว์า่ “Event” ซ่ึงเปน็เหตกุารณท์ีท่ำใหเ้กดิผลลพัธ์
หรอืการเปลีย่นแปลงบางอยา่งขึน้ เชน่ คลกิเมาสแ์ลว้เกดิเสยีงเพลง ซ่ึงเหตกุารณห์รอืจุดเปลีย่นเหลา่นีจ้ะเปน็
จุดทีเ่ราใส ่ActionScript  โดยเราสามารถใส ่ActionScript ได้ใน Panel Actions

วิธกีารเรยีกใชส้ครปิต์ใน Panel Actions
วธิกีารเรยีกใชส้ครปิตใ์นพาเนล Actions หรอืการใสแ่อค็ชัน่ใหก้บัมูฟวีน่ัน้ มีวธิกีารเขยีนผา่นโหลดการ

ทำงาน 2 โหมดคอื Script Assist และ Expert ซ่ึงเราสามารถสลบัไปสลับมาระหวา่งสองโหมดการทำงานได้
โดยกดคลิกที่ปุ่ม

ปุ่ม Script Assist
สำหรบัเขา้สูโ่หมดผูช่้วยเขยีน
สคริปต์ทำให้เขียนสคริปต์ได้
ง่ายขึ้น

Actions Toolbox
เกบ็คำสัง่ตา่ง ๆ ทีเ่ปน็ภาษา
ActionsScript ใช้เพิม่คำสัง่ดา้นขวามอื

Script panel
เป็นช่องสำหรับให้เราทำการ
เขยีน Script



โดยเราสามารถใส ่ActionScript ใหกั้บ Frame หรือ MovieClip หรือ Button เทา่นัน้โดย
ActionScript ทีเ่ขยีนใหกั้บ Frame, Movie Clip, Button ก็จะมกีารใชง้านทีแ่ตกตา่งกนั

การเขียน ActionScript ให้กับ Frame
หากเราตอ้งการเขยีน ActionScript ใหก้บั Frame โดยใหเ้ราคลกิเลอืก Frame (จริง ๆ แลว้ตอ้ง เปน็

Keyframe จึงจะเขยีน ActionScript ลงไปได)้ ตัวอยา่งเชน่
Stop () ;
หมายความวา่ใหห้ยดุ Playhead ไวท้ี ่Frame นี้

การเขยีน ActionScript ให้กับ Button
การเขยีน ActionScript ใหกั้บ Button จำเปน็จะตอ้งขึน้ตน้ดว้ย
on (event) {
............
}
ตัวอย่างเช่น

on (release) {
gotoAndPlay(1);
}

หมายความวา่เมือ่ทำการคลกิเมาสใ์ห ้Playhead ไปยงั Frame 1 และทำการเลน่

การเขยีน ActionScript ให้กับ MovieClip
การเขยีน ActionScript ใหก้บั MovieClip จำเปน็จะตอ้งขึน้ตน้ดว้ย
onClipEvent (event) {
............
}
ตัวอย่าง

onClipEvent (load) {
gotoAndPlay(1);
}
หมายความวา่เมือ่ Movieclip ถูกโหลดขึน้มาแลว้ให ้Playhead ไปยัง Frame 1 และทำการเลน่



Basia Action Script : 1
1) เปิดไฟล ์01racetrack ข้ึนมา
2 ) สร้างปุม่ขึน้มาบรเิวณพืน้ทีด่า้นซา้ยมอืของชิน้งาน

โดยทำการสรา้งสีเ่หลีย่มขึน้มาแลว้คลกิขวาและเลอืกคำสัง่  Convert to Symbol และเลอืก Symbol ชนดิ
Button

3 ) ทำการ Copy ปุ่มจากปุม่ทีพ่ึง่สรา้งขึน้มาอกี 3 ปุ่ม (รวมแลว้เราจะมปุ่ีมอยู ่4ปุ่มในตอนนี ้)
โดยในการ Copy นัน้ใหเ้ราทำการกดปุม่ Alt คา้งไวแ้ละดงึเมาสเ์พือ่ลากปุม่ออกมา จากนัน้เมือ่เราปลอ่ยเมาส์
ก็จะเปน็การ Copy ปุ่ม

กดปุม่ Alt
ค้างไว้และดึงเมาส์เพ่ือลากปุ่มออกมา
จากนั้นเมื่อเราปล่อยเมาส์
ก็จะเปน็การ Copy ปุ่ม

4 ) พมิพต์วัอกัษรวางบนปุม่ทัง้สีข่องเราตามภาพ
ปุ่ม 1 : Play
ปุ่ม 2 : Stop
ปุ่ม 3 : Mute
ปุ่ม 4 : Restart



5 ) ทำการ Test  Movie ด้วยคำสัง่ Control > Test Movie

เราจะเหน็วา่ Movie ของเราเปน็การแขง่รถเมือ่รถวิง่มาจนถงึจดุ Finish แลว้รถกจ็ะไมห่ยดุรถจะวิง่ตอ่
ไปเพราะวา่ปรกต ิFlash Movie จะทำการเลน่ Movie แบบวนซำ้ ในขัน้ตอนตอ่ไปเราจะทำการ ใส่ Action
Script แรกใหก้บังานของเรากค็อืการสัง่ให ้Movie ทำการหยดุเลน่เมือ่ Movie เลน่จบแลว้จะไมท่ำการเลน่ซำ้

6 ) ทำการสรา้ง Layer ขึน้มาใหม ่1 Layer และไปที ่Frame สุดทา้ย และใชค้ำสัง่ Insert Keyframe
( Frame สุดทา้ยของงานชิน้นีค้อื Frame ที ่100 พอด)ี

โดยเราอาจทำตัง้ชือ่ให ้Layer ทีเ่ราสรา้ง
ขึน้มาใหมว่า่ action และนำไวบ้นสดุเพือ่กนั
การสับสน

7 ) ยงัคงเลอืก Frame สุดทา้ยอยู ่ ขัน้ตอนตอ่ไปใหค้ลกิทีส่ามเหลีย่มบรเิวณนี้
เพือ่เปดิ Actions Panel จากนัน้พมิพ ์จากนัน้ใสค่ำสัง่ stop () ; ใหก้บั Frame สุดทา้ยของเรา

ดบัเบิล้คลกิเพือ่ใส่คำสัง่ stop () ;

หากเราทำการ Test
Movie ในตอนนี้
ก็จะพบวา่  Movie
ของเราจะไม่ทำการเล่น
ซ้ำอีกแล้ว



8 ) ทำการใสเ่สยีงใหก้บั Movie ของเรา โดยทำการสรา้ง Layer ขึน้มาอกี 1 Layer จากนัน้คลกิเลอืกที่
Frame แรก และทำการคลกิที ่ช่อง Sound ใน Properties และเลอืกเพลง Car_loop_1-2.aif

สร้าง Layer ขึน้มาใหม ่อาจทำการตัง้ชือ่ให ้Layer นีว้า่ Music

ทำการเลอืก Frame แรกอยูแ่ละทำการคลกิที ่ช่อง Sound
ใน Properties และเลอืกเพลง Car_loop_1-2.aif

เม่ือทำการ Test Movie จะพบวา่ Movie ของเรามเีสียงประกอบแลว้

9 ) ขัน้ตอนนีเ้ราจะทำการใส ่Action ใหกั้บปุ่ม Play และ Stop

คลกิเลอืกปุม่ Play และใส ่Action ใหกั้บปุ่มดงัรปู

ดบัเบิล้คลกิเพือ่ใส่คำสัง่ play () ;
ใหก้บัปุ่ม

คลิกเลอืกปุ่ม Stop และใส ่Action ให้กับปุ่มดังรูป

ดบัเบิล้คลกิเพือ่ใส่คำสัง่ stop () ;
ใหก้บัปุ่ม



หากเราทำการ Test Movie ของเราและทำการกดทีปุ่ม Play และ Stop กจ็ะพบวา่ เมือ่กดปุม่ Play
Movie ของเรากจ็ะทำการเลน่ แตถ่า้กดปุม่ Stop Movie ของเรากจ็ะทำการหยดุเลน่ โดยในขึน้ตอนตอ่ไปเรา
จะใช้คำสั่งเพื่อสั่งหยุดการทำงานของเสียง

9 ) เปิด Panel Behaviors ขึน้มา โดยใชค้ำสัง่  Window > Behaviors

จากนัน้ใหค้ลกิทีปุ่่ม Mute และใส ่Behaviors โดยใหค้ลกิทีปุ่่ม +
จากนัน้เลอืก Sound และตอ่ไปเลือก Stop All Sounds

คลกิทีปุ่่ม +

คลิกเลือก
Sound

คลิกเลือก
Stop All Sounds

หากเราทำการ Test Movie และทำการคลกิทีปุ่่ม Mute กดจะพบวา่ เสียง จะหายไปจาก Movie
ของเรา ขัน้ตอนตอ่ไปจะเปน็ขึน้ตอนสดุทา้ยซึง่จะเปน็คำสัง่ Restart  Movie ของเรา

9 ) ใหค้ลกิทีปุ่่ม Restart และคลกิทีปุ่่ม + จากนัน้เลอืก Movieclip และตอ่ไปเลอืก Goto and Play at
frame or label

คลกิทีปุ่่ม +

คลิก Movieclip

คลกิ Goto and Play
at frame or label



หากเราทำการ Test Movie และทำการคลกิทีปุ่่ม Restart กดจะพบวา่ Movie ของเราจะกบัไปเลน่ที่
Frame แรกเสมอ

คลิกทีปุ่่ม OK

คลกิทีปุ่่ม OK

ข้อสังเกตเพิ่มเติม
หากเราทำการสังในรายละเอียดการกำหนดสถานะในการใช้งานปุ่มก็จะสังเกตได้ว่าจะมีให้กำหนด

สถานะการใชง้านตา่ง ๆ ไดอ้ยา่งหลากหลาย แตใ่นขัน้ตอนทีเ่ราไดท้ดลองนีเ้ราไมไ่ดก้ำหนดสถานะของปุม่เลย
เพราะปกตปุ่ิมจะถกูกำหนดสถานะไวท้ี ่on (release) คอืสถานะเมือ่ผู้ใช้คลกิปุม่แลว้ปลอ่ยกใ็หท้ำตำคำสัง่
ซ่ึงเป็นคา่มาตรฐานของการกำหนดสถานะใหปุ่้ม ในแบบฝกึหดัทีเ่ราไดท้ำการทดลองนีต้อ้งการใชค้า่ Release
อยูแ่ลว้จงึไมต่อ้งทำการเปลีย่นแปลงคา่ใด ๆ แตห่ากเราตอ้งการทีจ่ะเปลีย่นแปลงสถานะการกดปุม่
เป็นแบบอื่นเราก็สามารถทำได้

เมือ่เราทำการใชง้าน Behaviors แลว้ Flash กจ็ะทำการเขยีน Script ใหเ้ราใน Action Script Panel
ด้วย

Script ของปุม่ Restart



Basia Action Script : 2
1) เปิดไฟล ์02scenes ข้ึนมา
จากนัน้ลอง Test Movie เพือ่ศกึษาดลัูกษณะของ Movie นี้

จะเหน็วา่ Movie นี ้มีเนือ้หาเริม่ตน้ทีย่าวอวกาศวิง่มาจากดา้นซา้ยมอืจากนัน้ยานอวกาศ กพ็ุง่ชนกบั
พืน้ดนิ และมนษุยต์า่งดาวกก็ระโดดออกมาจากยานอวกาศ

2) เราจะทำการแบง่ Movie นีอ้อกเปน็ Scenes จำนวน 4 Scenes โดยมวีธิกีารดงัตอ่ไปนี้

๐ ไปท่ี Frame ท่ี 111 และเลอืก Frame ท่ี 111 ของทกุ
Layer จากนัน้คลกิขวาและเลอืก Insert Keyframe ใหก้บั ทกุ
Layer

๐ คลกิเลอืก Frame ตัง้แต ่111 ไปจนถงึ Frame
สุดทา้ย จากนัน้คลกิขวาและเลอืก Cut Frames

๐ ยงัคงเลอืก Frame ตัง้แต ่111 ไปจนถงึ Frame
สุดทา้ย จากนัน้คลกิขวาและเลอืก Remove Frames



๐ ใช้คำสัง่ Insert > Scene

๐ จากนัน้เลอืก Paste Frames

๐ ไปท่ี Frame ท่ี 71 และเลอืก Frame ท่ี 71 ของทกุ
Layer จากนัน้คลกิขวาและเลอืก Insert Keyframe ใหก้บั ทกุ
Layer

๐ คลกิเลอืก Frame ตัง้แต ่71 ไปจนถงึ Frame
สุดทา้ย จากนัน้คลกิขวาและเลอืก Cut Frames

๐ ยงัคงเลอืก Frame ตัง้แต ่71
ไปจนถงึ Frame สุดทา้ย จากนัน้คลกิขวา
และเลอืก Remove Frames



๐ ใช้คำสัง่ Insert > Scene

๐ จากนัน้เลอืก Paste Frames

 จากขัน้ตอนที ่2 นีเ้ราจะได ้Scene ขึน้มา 3 Scene ซ่ึงในขัน้ตอนตอ่ไปเราจะสรา้ง Scene เพิม่ขึน้อกี
1 Scene

3) เราจะทำการแบง่ Movie นีอ้อกเปน็ Scenes จำนวน 4 Scenes โดยมวีธิกีารดงัตอ่ไปนี้

๐ คลกิที ่Frame ที ่58 จากนัน้เลอืก Insert Keyframe

๐ คลกิขวาเลอืก Keyframe ทัง้หมดทีพ่ึง่ทำการ
Insert จากนัน้เลอืก Copy Frames

๐ ใช้คำสัง่ Insert > Scene

๐ จากนัน้เลอืก Paste Frames



๐ คลกิที ่Frame ที ่5 จากนัน้คลกิขวาเลอืก Insert
Keyframe ใหกั้บทกุ Layer

๐ ใช้เครือ่งมอื Free Transform Tool
ขยายวตัถทุัง้หมดใหใ้หญข่ึน้ ดงัภาพ
ด้านข้าง

๐ คลกิที ่Frame ที ่10 จากนัน้คลกิขวาเลอืก Insert
Keyframe ใหกั้บทกุ Layer

๐ ใช้เครือ่งมอื Free Transform Tool
ขยายวตัถทุัง้หมดใหใ้หญข่ึน้ ดงัภาพ
ด้านข้าง

๐ คลกิที ่Frame ที ่15 จากนัน้คลกิขวาเลอืก Insert
Keyframe ใหกั้บทกุ Layer



๐ คลกิเลอืกทีต่วัของมนษุยต์า่งดาว  จากนัน้คลกิทีปุ่่ม
จาก  Properties และเปลีย่น Symblo alie body ใหเ้ป็น alien body sign

๐ ลากตวัอกัษร sign text 1 จาก
Library มาวางบนปา้ยของเรา จัดวาง
ตำแหนง่ดงัภาพ  จากนัน้ไปที ่Frame ที่
20 และทำการ Insert KeyFrames ใหก้บั
ทกุ ๆ Layer

๐ คลกิเลอืกทีต่วัของมนษุยต์า่งดาว  จากนัน้คลกิทีปุ่่ม
จาก  Properties และเปลีย่น Symblo alien body sign ใหเ้ปน็
alien body 2signs

๐ ลากตวัอกัษร sign text 2 จาก Library มาวางบนปา้ยของเรา จัดวางตำแหนง่ดงัภาพ



3. ในขัน้ตอนนีเ้ราจะเริม่ใส่ Action Script ใหก้บั Movie ของเรา โดยมขีัน้ตอนดงัตอ่ไปนี้

คลิกที ่Scene และเลอืก Scene 1
จากนัน้ Insert Layer และตัง้ชือ่ Layer ใหมท่ีพ่ึง่สรา้งขึน้มาวา่ actions

๐ ไปท่ี Frame ท่ี 110 ของ Layer actions และ Insert Keyframe

๐ จากนัน้คลกิที ่                     เพือ่เปดิ Actions Panel

๐ ดบัเบิล้คลิกที ่            เพือ่ใส่ Action  stop () ;

๐ ใหท้ำซำ้ขัน้ตอนที ่3 โดยใส ่Action Script     stop () ; ใหกั้บ Frame สุดทา้ยของ Scene 2, Scene
3, Scene 4 โดยควรทำการสรา้ง Layer ขึน้มาใหมส่ำหรบัใส่ Action Script

เมือ่ทำการ Test Movie ก็จะพบวา่ Movie จะเริม่เลน่ตัง้แตต่น้จน
มาจบที ่Frame ท่ี 110 ของ Scene 1 เพราะเราไดท้ำการใส ่Action Script
stop () ;  ใหก้บั Frame ที ่110 ไว้

4. ในขัน้ตอนนีเ้ราจะเริม่ทำการสรา้ง Inter Active Movie โดยใหก้ลับไปที ่Scene 1 ก่อน
๐ สร้าง Layer ขึน้มาใหมใ่น Scene 1 และตัง้ชือ่ว่า

Button จากนัน้ใหส้ร้าง Button ขึน้มาบน Layer
ทีเ่ราสรา้งขึน้มาใหม ่โดยใหส้ร้างใน Frame ที ่110 เพือ่
ไม่ใหปุ่้มปรากฎใน Frame อ่ืน ใหปุ่้มปรากฎใน Frame ที ่110



๐ พมิพต์วัอกัษร Next ลงบนปุม่ทีส่ร้างขึน้มาใหม่

๐ จากนัน้ใหค้ลกิทีปุ่่มเพือ่เลอืกปุม่  และใหค้ลกิที่
เพือ่เปิด Actions Panel

๐ ใหค้ลกิที ่                 และเลอืกชอ่ง Scene ใหเ้ปน็ Scene 2

ดบัเบิล้คลกิที ่goto

เลอืก Scene 2
เลอืก Go to and play

๐ ใหท้ำซำ้ขัน้ตอนที ่4 โดยใสปุ่่มใหกั้บทกุ Scene ทีเ่หลอื และเปลีย่น ช่อง Scene 2 ใหเ้ปน็ Scene
ที่เราต้องการ



Basia Action Script : 3

1) สร้าง Document ข้ึนมาใหมโ่ดยใหมี้ขนาด 750 x 450 px
จากนัน้ให ้Save file ไวใ้น foder เดยีวกบั Movie ทีเ่ราตอ้งการ Load

2) สร้าง Button ขึน้มา และพมิพ์
คำวา่ Load ลงบน Button

3) เปิด panel Behaviors ข้ึนมาโดยไปที ่Windows
>Behaviors   จากนัน้ใหค้ลกิทีปุ่่มเพือ่เลอืกปุม่ และคลกิที่
และเลอืก Load External Movieclip

4) พมิพช่ื์อ file ทีต่อ้งการ Load ในชอ่งนี้

ใน Work Shop นีเ้ราจะมาทำการเรยีนรูค้ำสัง่ Load External Movieclip



Basia Action Script : 4
ใน Work Shop นีเ้ราจะมาทำการเรยีนรูค้ำสัง่ Load Graphic

1) สร้าง Document ข้ึนมาใหม่
โดย ให ้Save File ทีส่ร้างขึน้มาใหมน่ี้
ใหอ้ยูใ่น foder เดยีวกบั Graphic (รูปภาพ)
ทีเ่ราตอ้งการ Load
จากนัน้สรา้ง button ขึน้มา

2) ทำการ Copy ปุ่มขึน้มาใหม ่อีก 2 ปุ่มและจดัวางดงัภาพประกอบ

3) ทำการพมิพต์วัอกัษรใหก้บัปุ่มดงัภาพประกอบ

4) สร้าง Movie clip ขึน้มาใหม ่โดยใหเ้ปน็สีเ่หลีย่ม
เหมอืภาพประกอบ ให้มีขนาด 225 x 300
(ขนาดนีค้อืขนาดเทา่กบัภาพทีเ่ราตอ้งการ Load)
และทำการตัง้ชือ่ Instance ใน Propertiesวา่ Load

5) เปิด panel Behaviors ขึน้มาโดยไปที ่Windows >Behaviors   จากนัน้ใหค้ลิกทีปุ่่ม Pic1 เพือ่
เลือกปุม่  และคลกิที ่                จากนัน้เลอืก  Load Graphic



6) เลอืก file ทีเ่ราตอ้งการ

7) เลือก Movie clip
ทีเ่ราตอ้งการให ้รูปของเรา Load

8) ใหท้ำซำ้ขัน้ตอนที ่5-7 แตใ่หเ้ปลีย่นชือ่ file ทีเ่ราตอ้งการ load

9) ใหค้ณุสรา้งปุม่ขึน้มาอกีปุห่นึง่ จากนัน้พมิพต์วัอกัษรวา่ Unload

10) คลิกที ่Movieclip

11) เลือก Unload Movieclip

11) เลือก Movieclip ท่ีเราตอ้งการ Unload
ในทีน่ีค้อื Load



Basia Action Script : 5
ใหเ้ปิด File website ข้ึนมา ใน work shop น้ีเราจะลองจดัทำ Website  Jewelry.com  โดย Website

Jewelry.com จะมีลักษณะดงันี้

เมือ่ผู้ใช้เขา้เยีย่มชม Website กจ็ะพบหนา้
แรก ซ่ึงจะทำการโหลดขอ้มูลของ Website ขึน้มา

ProgressBar ทำการโหลดขอ้มูล

เมื่อโหลดข้อมูลทั้งหมดเสร็จก็จะเข้าสู่หน้า
Home

Loader โหลดขอ้มูลรูปภาพ jpg
จากภายนอก

หนา้ Products มีการโหลดขอ้มูลรูปภาพ jpg
จากภายนอก และมกีารใช ้UIScrobar เพือ่ช่วยใน
การจัดการกับตัวอักษรที่มีเนื้อหามากเกิดจะแสดงได้
ใน 1 หน้าจอ

Loader โหลดขอ้มูลรูปภาพ jpg จากภายนอก

UIScrobar



Loader โหลดขอ้มูลรูปภาพ jpg จากภายนอก

หนา้ News มีการโหลดขอ้มูลรูปภาพ jpg
จากภายนอก

หนา้ Contact มีการโหลดขอ้มูลรูปภาพ jpg
และไฟล ์Swf จากภายนอก

Loader โหลดไฟล ์Swf จากภายนอก

หลังจากทีไ่ดท้ราบลกัษณะของ Jewelry.com เรยีบร้อยแลว้ตอ่ไปเราจะมาเรมิสร้าง Website
Jewelry.com โดยมข้ัีนตอนดงันี้

1. ใหส้ร้าง Layer ขึน้มาใหมแ่ละตัง้ชือ่ Layer วา่ Action

จากนัน้ Insert Keyframe ใหก้บั frame ทกุ Frame
(ยกเวน้) Frame ที ่1 ทีมี่ Keyframe ใหโ้ดย
อัตโนมัติอยู่แล้ว



2. ให้คลิกที ่                     เพือ่เปิด Actions Panel

๐ ดบัเบิล้คลิกที ่            เพือ่ใส่ Action  stop () ;

๐ ใหท้ำซำ้ขัน้ตอนทีส่องใหก้บั Frame ทกุ Frame

3. ขัน้ตอนนีเ้ราจะใสค่ำสัง่ ให ้Website ของเรามกีาาร Link ไปยงัหนา้ตา่ง ๆ กลบัไปที ่Frame ที ่1
จากนั้นคลิกที่ปุ่ม

๐ ใหค้ลกิที ่                     เพือ่เปดิ Actions Panel  จากนัน้กดปุม่
เพื่อเปิดการทำงาน

๐ ดับเบ้ิลคลิกที ่            เพือ่ใส่ Action  gotoAndStop
โดยในชอ่ง Frame ใหพิ้มพ ์เลข 1 ลงไป

ดบัเบิล้คลกิ

ดบัเบิล้คลกิ

พิมพ์ 1 ในชอ่ง Frame

เลือก Go to and stop



๐ ตอ่ไปใหท้ำซำ้ขัน้ตอนที ่3 ทัง้หมดโดยเปลีย่นคา่ทีช่่อง Frame                      ของปุม่ตา่ง ๆ
ให้เป็นค่าดังนี้

ปุ่ม Products ช่อง Frame ใหใ้ส่เลข 2

ปุ่ม News ช่อง Frame ใหใ้ส่เลข 3

ปุ่ม Contact ช่อง Frame ให้ใส่เลข 4

4. ในขัน้ตอนนีเ้ราจะกำหนด Path ใหก้บั Loder ของเรา โดยมขีัน้ตอนดงัตอ่ไปนี้

ใหค้ลกิที ่Frame ที ่1 จากนัน้คลกิที ่Loder จากนัน้ใสค่า่ใน Paramaters ทีช่่อง
ContentPath ให้เป็น Pic01.jpg

คลิกที ่Loader ใน Frame ที ่1

พิมพ์ Pic01.jpg ท่ีช่อง
ContentPath

*** ปกต ิLoader จะอยูใ่น Panel Components
ซ่ึงวธิกีารเรยีกใชก้เ็พยีงแตท่ำการคลกิ และลาก
ลงมาใชง้านบน Stage แตใ่น Work Shop นี้
ไดเ้ตรยีมไว้

๐ ใหค้ลกิที ่Frame ที ่2 จากนัน้คลกิที่
Loder จากนัน้ใสค่า่ใน Paramaters ทีช่่อง
ContentPath ให้เป็น Pic02.jpg



๐ ใหค้ลกิที ่Frame ที ่3 จากนัน้คลกิที่
Loder จากนัน้ใสค่า่ใน Paramaters ทีช่่อง
ContentPath ให้เป็น Pic03.jpg

๐ ใหค้ลกิที ่Frame ที ่4 จากนัน้สงัเกตดจูะเหน็วา่ Frame ที ่4 มี Loader อยู ่2 อัน โดยใหเ้ราใสค่า่
ในชอ่ง ContentPath ดงัตอ่ไปนี้

๐ คลกิที ่Loder จากนัน้ใสค่า่ใน
Paramaters ท่ีช่องContentPath ให้เป็น
Pic04.jpg

๐ คลกิที ่Loder จากนัน้ใสค่า่ใน Paramaters ทีช่่อง
ContentPath ให้เป็น map.swf

5. ในขัน้ตอนนีเ้ราจะใช ้UIScrobar เพือ่ช่วยในการจดัการกบัตวัอกัษรทีมี่เนือ้หามาเกดิจะแสดงได้
ใน 1 หน้าจอ

๐ ใหค้ณุทีท่ี ่Frame ที ่2 (หนา้ Products)
จะเหน็วา่มตีวัอกัษรวางอยูด่า้นขวามอื ซ่ึงตวัอกัษรนี้
มีความยาวคอ่นขา้งมาก ไม่สามารถใสไ่วไ้ดใ้น 1 หนา้
จอเราจะใช ้UIScrobar มาชว่ยในการจดัการ
โดยมีขั้นตอนดังต่อไปนี้



๐ คลกิที ่          Text Tool เพือ่สร้าง Text กล่องขอ้ความ Text แบบ Dynamic Text

จากนั้นคลิกและลากเพื่อสร้าง
กล่องข้อความ

๐ ใหค้ลกิที ่                   ใน Components จากนัน้ใหล้ากลงมาวางกลอ่งขอ้ความทีพ่ึง่สรา้งขึน้มา

๐ จากนัน้ใหเ้ราทำการ Copy text ทีบ่ริเวณขวามอืทีอ่ยูน่อก Stage มาวางในกลอ่งขอ้ความของเรา
ถา้เราทำการ Test Movie กจ็ะพบวา่ขอ้ความทีย่าวเกนิกลอ่งขอ้ความจะสามารถเลือ่นดไูดโ้ดยจะม ีScrollBar
ปรากฎให้เราสามารถเลื่อนดูข้อความได้

คลิกและลากมาวางบน
กล่องข้อความ



6. จากขัน้ตอนที ่1 - 5 เราไดส้ร้าง Website Jewelry.com ขึน้มาเรยีบรอ้ยตอ่ไปเราจะมาสรา้ง
Progress Bar เพือ่ทำการโหลดและคา่ในการโหลดขอ้มูลโดยมขีึน้ตอนดงัตอ่ไปนี้
๐ ให ้Save File website และทำการ Export Movie โดยใหต้ัง้ชือ่ Movie วา่ website
๐ จากนัน้เปดิไฟล ์loader ขึน้มา ซ่ึงใน File นีจ้ะมวีตัถอุยู ่3 ช้ินคอื
1. Loader   2.ProgressBar  3.Movieclip รูปแหวน   โดยเราตัง้ชือ่ Instance ใหก้บัวตัถทุัง้ 3 ดงันี้

Loader ต้ังช่ือเป็น loadmovie

ProgressBar ตัง้ชือ่เปน็ pro

Movieclip ตัง้ชือ่เปน็ ring

7. ใหค้ลกิที ่Loader (ตอนนีมี้ช่ือ Instance
Name แลว้วา่ loadmovie) จากนัน้พมิพท์ีช่่อง
Content Path ใน Parameters ว่า website.swf
(เพือ่ให ้Loader โหลด File website.swf ท่ีเรา
ได ้Export Movie ไวก้อ่นหนา้นีแ้ลว้)

7. ใหค้ลกิ ProgressBar จากนัน้พมิพ์
this_parent.loadmovie ลงในชอ่ง Source (เพือ่ให้
ProgressBar ทำการอา่นคา่ปรมิาณการโหลด
Loader ท่ีเราตัง้ช่ือ Instance Name ว่า loadmovie
ไว้ก่อนหน้านี้)

8. มาถงึขัน้ตอนนีห้ากเราทำการ Test Movie กจ็ะพบวา่ Progress Bar ไดเ้ริม่ทำงานแลว้ แตเ่มือ่
Progress Bar ทำการโหลดขอ้มูลมาเสรจ็แลว้ Progress Bar ไม่หายไปทำใหท้บักบัเวบ็ไซตข์องเราซึง่เรา
ตอ้งสัง่ซอ่น Progress Bar เมือ่ โหลด Movie ของเราเรยีบร้อยแลว้ โดยมขีัน้ตอนดงันี้

๐ใหค้ลกิที ่Loader จากนัน้คลกิทีปุ่่ม                     เพือ่เปดิ Action Panel



8. จากนัน้ใหด้บัเบิล้คลกิทีปุ่่ม                  และ คลกิทีปุ่่ม                              เพือ่ยกเลกิ Script Assist
เพราะเราจะพมิพ ์Action Script ดว้ยตวัเอง ถ้าหากเปดิ Script Assist ไว้โปรแกรมจะไมอ่นญุาตใิหเ้ราพมิพ์
Script ลงไป

ดบัเบิล้คลกิ

9. จากนัน้พมิพ ์Action ลงไปดงัตอ่ไปนี้
on (complete) {

this._parent.ring._visible = false;
this._parent.pro._visible = false;

}

10. ให้ลอง Test Movie ดูก็จะเหน็วา่ Progress Bar และ Movieclip ring จะหายไปเมือ่โหลดขอ้มูล
เสร็จหมดแลว้  และหากการโหลดขอ้มูลเรว็มากจนเราไมส่ามารถมองไดทั้นใหเ้ราคลกิที ่View และเปลีย่น
Downloadseting เป็น DSL
จากนัน้คลกิที ่Simulate Download
อีกครั้ง


